• Pardon our dust as we work on some regularly scheduled forum maintenance. You may notice some missing features during this time. Thank you for your patience!

Question New build issue, on/off cycle, black monitor, no peripheral power

Aug 11, 2019
1
0
10
0
I recently just completed my very first build and it worked perfectly for two days! However on the third day I went to turn on my new build and it didnt provide power to the keyboard (which usually lights up) and the monitor stayed black. The computer then turned itself off and then back on again and cycled through an on off cycle with no discernible pattern before turning off and staying off.

I have followed the troubleshooting guidelines, removing components until I was eventually down to just the mobo, cpu, cpu cooler, and psu. However, the on/off cycling continued. I also tried another PSU and resetting CMOS but the problem remained. There are no beeps or sounds at all when I turn it on. From what I understand this is most likely a motherboard issue. I plan to return it for a replacement and hope that the issue will be solved.

I was wondering if anyone else has had a similar experience and what they did to fix it. I am also concerned that the problem could have been caused by the drivers that I downloaded from the motherboards website or from a bad copy of windows etc.. however I dont know the validity of that concern and if bad drivers could even result in a problem like this. If anyone can provide any additional information I would really appreciate it.

System info:
CPU: AMD Ryzen 5 2600X 3.6 GHz 6-Core Processor
CPU cooler: Deepcool GAMMAXX 400 74.34 CFM CPU Cooler
mobo: ASRock X470 Master SLI/AC ATX AM4 Motherboard
ram: G.Skill Value 8 GB (1 x 8 GB) DDR4-2666 Memory
GPU: XFX Radeon RX 580 8 GB GTS XXX ED Video Card
PSU: Corsair RMx (2018) 650 W 80+ Gold Certified Fully Modular ATX Power Supply

Drivers:
taken from: https://www.asrock.com/MB/Intel/Z390 Phantom Gaming-ITXac/index.us.asp#Download
Realtek audio driver
intel bluetooth driver
INF driver
Intel LAN
Intel management engine
Phantom gaming tuning
Intel thunderbolt
Intel rapid storage technology

 
Aug 24, 2019
3
0
10
0
I've been dealing with that for a month now,replacing the psu helped me for two days,then it started again. Last I replaced the 3v battery and it held it together for two weeks,just yesterday it started again.but,my build is 5 years old so it may as well be a mobo in my case,in your case might be a bad 3v battery not registering RAM in bios on start up.
 

ASK THE COMMUNITY

TRENDING THREADS