[SOLVED] New build...it seems to boot with one PSU but not another. Help?

LordMaul

Commendable
Jan 4, 2017
29
0
1,530
0
Hi all,

I read the rules and the "read this prior to posting 'no boot' issues" thread carefully but I think I'm at my wits end as to why this is happening. Basically it appears my new components work with my PSU from my old rig (Corsair TX 750M) but not with the PSU I bought for my new one (EVGA 850BQ Modular).

  • AMD Ryzen 3600X (with Wraith Cooler)
  • MSI B450M Mortar Max motherboard
  • 32 GB RAM, split into chunks of 8GB
  • GTX 1050TI
  • Corsair 250GB M.2 510 NVME drive
...With minimal parts assembled (one stick of ram, processor and vital cables) my new PC seems to work perfectly (goes to Windows setup, memory setup, etc) with the old PSU but not the new one. When I first assembled my new PC in my new case I didn't expect to run into any issues (I'm a relatively experienced builder) so I was quite surprised that my PC started for a split second and then shut down. This happened repeatedly, despite tweaks I made. That was with the new PSU (EVGA). At that point, I didn't know what the issue with the build was; so I extracted everything, re-seated and re-pasted the CPU, reduced it to the barebones and went through some testing. It still didn't work so I pulled apart my old PC and to my surprise my old PSU works with it nicely.

My question then turned to whether I'd bought a faulty PSU...but when I tested my EVGA PSU with the supplied PSU tester, it worked. At least it spun up, fan working. So I don't think my new PSU is broken, yet it won't work with my new components.

Long term, I don't really want to use a 6 year old PSU with a brand new PC. Does anyone have any suggestions as to why it isn't working with my new PC?

I'd be grateful for any advice, thanks.
 

ASK THE COMMUNITY

TRENDING THREADS