Question New build, motherboard driver's inop

Feb 12, 2019
3
0
10
0
Hello

I recently bought a gigabyte aorus pro wifi z390 mini itx board, new ram, new cpu i5 9600k. The rest of my comments are from my previous PC.

I moved the drives over, connected and booted up to Windows, logged in fine from my ssd. I am able to access my drives no problems.

The problem is my motherboard. I tried to download driver's from the CD and the downloading/installation was just getting stuck at random percentages forever, giving them an hour to move with no progress. I tried downloading the Ethernet drivers onto a flash drive, connected flash drive but the USB port doesn't recognize the flash drive. It doesn't recognize it in any ports. I tried my phone as well, it didn't recognize my phone. Unplugging my mouse and keyboard kills them unless I hard restart the PC.

Also when I try to restart my PC from Windows, it is stuck on restarting circle. When I try to shut down, everything goes black but the lights and fans in my PC stay on.

The motherboard has no 2.0 USB ports, do I need a 3.0 USB drive to have it be recognized?

I didn't uninstall driver's from my previous motherboard, is that the reason I could be having problems? Should I just reinstall Windows?

If the motherboard doesn't recognize my flash drive, will I be able to boot windows from the flash drive through bios?

I'm at a loss of what to do.
 

ASK THE COMMUNITY