Question New build NO DISPLAY - ASUS PRIME B550M-A with AMD RYZEN 5 3600

Dec 5, 2020
3
0
10
0
Hi everyone,

I have an issue with a ASUS PRIME B550M-A with AMD RYZEN 5 3600 where there is no display.

Everything powers on correctly and everything is plugged in (I have removed and reinserted everything to check). I am running 2x CORSAIR Vengeance LPX 16GB DDR4 sticks and a 1TB WD Blue SN550 Nvme SSD, Inc. 600w power supply.

I have tested each RAM stick individually in all 4 ports. I've also tried different hdmi cables and screens. I had wondered if a bios update was required, however the ASUS website suggests there are only known issues with the 400 Series, not the 500.

I have just tried the motherboard outside of the case with the minimum plugged in (CPU fan, power etc) but cannot figure this one out.

Thanks everyone,

Tom
 

Lutfij

Titan
Moderator
Welcome to the forums, newcomer!

What is the make and model of your discrete GPU and the make and model of your PSU? 600W is the wattage, not it's model number. As for the display, your Ryzen processor does not have an iGPU so you won't get any display while plugged into the motherboard display outputs.
 
Dec 5, 2020
3
0
10
0
Thanks Lutfij!

Apologies, as you can probably tell my knowledge is basic-ish!

The GPU is quite old, it is a Nvidea Geforce GTX 650 whilst the PSU is a CORSAIR CX600.

Thanks again,

Tom
 
Dec 5, 2020
3
0
10
0
Just to add, after more testing it appears that the GPU turns off (fan stops) when a stick of memory is inserted. Without the memory the GPU runs (although there is still no display).

To confirm that the hdmi slot on the GPU is being used.
 
Feb 24, 2021
1
0
10
0
Did you fix it? I have the same issue but my setup is:
- ASUS PRIME B550M-A (WIFI)
- AMD RYZEN 5 3600
- 750 watt psu
- G.SKILL Trident Z Series 32GB RAM (2 x 16GB) DDR4 3200Mhz CL16 1.35v Desktop Memory F4-3200C16D-32GTZ 16-18-18-38
- Samsung 980 Pro 1TB NVMe PCIe 4.0 M.2 SSD
- GeForce GTX 1080

When I took the ram out (so no dimm slots had ram) the board didn't make any error beeping sounds
 

Haywardi

Prominent
Nov 8, 2019
10
1
515
0
I am coming to this topic late, but seem to have the same problem and think there may be a design flaw with the Asus B550m-a.

First board I had I experienced instability and system crashes. Replaced under warranty. Both board had the same problem as described here but by accident I found if I woke the monitor manually everything would work without problem.

However, last week, I experienced a new problem, ethernet would stop working and then the Windows 11 (yes I do mean 11) UI would just hang. Windows was still working because my mouse would still move around and could still click on windows to activate them, but I could not type so my keyboard was not working.
 

ASK THE COMMUNITY