Question New build, pc only turns on when GPU is connected. How to tell if it's GPU or motherboard?

Jan 3, 2019
19
1
15
0
Hey guys,

So I built my first computer today and could'nt have been happier when everything turned on. Unfortunately when I connected it, it appeared to have no signal. I removed the gpu and now I'm getting a signal. My question is, how do I determine if it's the GPU or the motherboard that's the problem? I heard crackling of pins as I inserted it which made my heart drop as it's a $500 gpu so I'm not sure which component is damaged. Thanks for any help.


Edit: I'm 99% sure it's in the right PCe slot. I put it on the top one with this motherboard --> https://www.msi.com/Motherboard/mpg-z390-gaming-edge-ac. It's also an RTX 2070 gpu.

I'm also downloading windows 10 now. Maybe there's a program I can run to further identify the issue. If so, let me know.
 
Last edited:
Jan 23, 2019
40
0
30
0
Hey guys,

So I built my first computer today and could'nt have been happier when everything turned on. Unfortunately when I connected it, it appeared to have no signal. I removed the gpu and now I'm getting a signal. My question is, how do I determine if it's the GPU or the motherboard that's the problem? I heard crackling of pins as I inserted it which made my heart drop as it's a $500 gpu so I'm not sure which component is damaged. Thanks for any help.


Edit: I'm 99% sure it's in the right PCe slot. I put it on the top one with this motherboard --> https://www.msi.com/Motherboard/mpg-z390-gaming-edge-ac. It's also an RTX 2070 gpu.

I'm also downloading windows 10 now. Maybe there's a program I can run to further identify the issue. If so, let me know.
First of all what the hell did you do to hear crushing pins? Its not hard to install a gpu. Ya you probably bent something on the PCIe slot on your motherboard or the Pins on your GPU. What CPU are you using? Does it have Dedicated graphics? Are you getting any power to your GPU? Fans Spinning, ect?
 

ASK THE COMMUNITY

TRENDING THREADS