Question New build pc problem, stuck on ROG logo

isatis.ee

Prominent
Sep 4, 2017
3
0
510
0
Hi there!

So I just bought some new components recently so I could make my own pc. I plugged in everything correctly, did a last check on the PSU cables. When I first powered the PC on it got stuck on the Republic of Gamers boot logo, i thought this would be normal because i bought a new SSD as well and thought that that one might compromise the one i used before. So I put my old SSD as boot #1 but nothing happened and it was still stuck with the boot logo of ROG. So I made a USB Boot with windows 10 creation tool but even with that it's still stuck on the boot logo.

Could anyone help me out please?

My specs:
Motherboard: ASUS Z290-F
CPU: I7 8700
CPU Cooler: dark rock 4 BE QUIET
RAM: Geil EVO POTENZA DDR4 2400
GPU: GTX 1060 6GB ASUS

Thanks for any help you guys could provide me
 
Apr 30, 2019
73
8
45
0
Is your bios updated? Are your bios configurations correct? Is your Ram faulty? There are numerous questions on why your pc is not going past that logo but one question I will ask.... When the pc gets stuck at the logo, does your hdd led stop blinking? And how much time have you recorded being stuck on the bios screen?
 

isatis.ee

Prominent
Sep 4, 2017
3
0
510
0
Is your bios updated? Are your bios configurations correct? Is your Ram faulty? There are numerous questions on why your pc is not going past that logo but one question I will ask.... When the pc gets stuck at the logo, does your hdd led stop blinking? And how much time have you recorded being stuck on the bios screen?
My BIOS is updated to the latest version. I do not know if my BIOS configurations are correct. I have got an all in one front panel cable from my case ( NZXT H500 ) so i don't see any leds on it. 30 Times atleast, and it's infinite
 

ASK THE COMMUNITY

TRENDING THREADS