Question New build PC - Wont post - Is RAM compatible

May 18, 2020
4
0
10
0
I've just started a new build and when I turn the power on, everything seems to work correctly. Fans on CPU, Light on GPU, Power button works and resets. However nothing is being detected on the monitor.

Two Questions:

1. I am using the HDMI out from my graphics card, does it matter what port I use during initial build?

2. I am using 3600Mhs RAM, the motherboard says it supports 3200+, would this prevent it from booting?

Heres my spec below:
---------------------------------------------------------------------------------------------------------------------------
Motherboard:
B450M - HDV R4 (Big sticker on front of box saying its Ryzen 3000 Desktop ready)

CPU:
Ryzen 5 3600

GPU
Radeon RX 580

RAM
Corsair VENGEANCELPX16GB (2x 8GB) DDR4 3600 (Pc4-28800) C181.35V Desktop Memory

SDD
Western Digital WDS500G2B0B WD Blue 3D NAND Internal SSD M.2 SATA, 500 GB
---------------------------------------------------------------------------------------------------------------------------------

This motherboard doesn't seem to have an onboard speaker, so no beeps or anything. If not one of the two issues above, is there anything else it could be?

I've tried removing the RAM and still no beeps.
I've tried removing the card and still nothing.
I've removed the heatsink and reset the CPU.
I've reset the G card and RAM.
I've triple checked all cables and fan wires.
 
Go through this check list.


You may want to get pc speaker for diagnosing purposes.
 
May 18, 2020
4
0
10
0
Ive replaced the RAM with 3200MHz and still not posting.

What about this question below, should this matter?

1. I am using the HDMI out from my graphics card, does it matter what port I use during initial build?
 
May 18, 2020
4
0
10
0
Just for info, It seems the motherboard wasnt suited for the processor, even though it was supposed to be. Got a new motherboard (B450 Max)and all worked as exoected.
 

ASK THE COMMUNITY

TRENDING THREADS