Question New Build - USB will not work

Jan 25, 2020
2
0
10
0
I have just finished putting my new build together. I have plugged in all necessary parts, everything powers up no problem, I just cannot get my mouse/keyboard to get detected.

This then becomes a big issue because I cannot access bios to install my OS and my monitor won't display video unless the keyboard/mouse are moved.

I have been trying to solve this problem for the past hour and I am about to freak out. The mobo is MSI X570 A pro, I am attempting to plug in a logitech g15 keyboard (its about 7 years old) and a razer deathadder (just bought it). I've tried a CMOS reset but that did nothing. Please give me any ideas, I am probably going to best buy to get a basic keyboard and see if I have any luck there.
 
Jan 25, 2020
2
0
10
0
I've tried all the ports.

MSI X-570 A Pro
AMD Ryzen 7 2700x w/ Wraith Cooler
Gigabyte GTX1060 3gb
EVGA 500GD 500w PSU
16gb Corsair Vengeance DDR4 3200
2tb Seagate Barracuda HD
512gb Samsung Evo SSD
Logitech G15 keyboard
Razer Death Adder mouse
 
Jan 8, 2020
92
14
35
0
HI,

reset the Bios read the M/B's manual to know how. Sometimes set the jumper + removing the BIOS battery is an extra step.

What is the debug status of the motherboard?

If the above actions fail connect a keyboard to the PS/2 port.
 

COLGeek

Cybernaut
Moderator
Check your BIOS and see if the USB ports are disabled (not likely but worth checking).

Also, double-check the ports to make sure nothing is protruding into them, that shouldn't be (like the little grounding fingers on some ATX panels).

If your front panel ports are connected to your motherboard directly, remove those connections until you know the rear panel ports work properly.
 

ASK THE COMMUNITY

TRENDING THREADS