Question New Build Very Slow / Restarts

Aug 2, 2022
2
0
10
0
I finished my build yesterday and installed windows 10. Installed the windows updates it restarted a couple of times to install the updates.
After updates were done I opened Microsoft Edge to get chrome and install gpu driver but as I type something the computer restarted. I am not able to search for anything. The system has been very laggy, when I try todrag windows explorer I can clearly see thelag in mouse movement and everything. I triedplaying a 1080p video from a flash drive but it was also laggy af.

This was happening after I reinstalled the windows to do everything fresh, yesterday I was able to install windows and get few software installed. While updating GPU driver the system crashed and restarted. After restarting I installed a couple of games (SQUAD & WARZONE) when I launch any game the screen goes black the system is run but not responsive, I cannot open task manager or minimise or anything. I have to force restart the PC.
Then I tried playing youtube videos they were lagging af and then I tried running Heaven Stress test but the system got as soon as it started. I have no idea what is wrong, someone please guide me.

IMP points: -
GPU is installed using the PIE expansion cable using Thermaltake PCIe 3.0 expansion cable came with the casing(Thermaltake Core P3)
  • GPU power cables are installed correctly (14 Pins)
  • Monitor is connected using DP (165Hz, 2k)
Specs:
PSU Cooler Master 850
RTX 3070 gigabyte
i5 12400F Z690 Gigabyte Elite V1 (BIOS updated to latest F20a)
16 GB Vengence PRO RAM (XMP enabled for 3200 Mhz)
1TB Samsung 980 Mvme 2.0 SSD
 

Lutfij

Titan
Moderator
Welcome to the forums, newcomer!

Coolermaster have a number of 850W units in their portfolio. Which one do you have? Try and work without the PCIe riser cable and see if the issue is alleviated. You're also advised to uninstall your GPU drivers using DDU, then manually reinstall your GPU's latest drivers in an elevated command, i.e, Right click installer>Run as Administrator.

Where did you source the installer for your OS?
 
Last edited:
Aug 2, 2022
2
0
10
0
Welcome to the forums, newcomer!

Coolermaster have a number of 850W units in their portfolio. Which one do you have? Try and work without the PCIe riser cable and see if the issue is alleviated. You're also advised to uninstall your GPU drivers using DDU, then manually reinstall your GPU's latest drivers in an elevated command, i.e, Right click installer>Run as Administrator.

Where did you source the installer for your OS?

I have Cooler Master. RM 850 Fully Moduler ATX Power Supply and I got the windows installer from official Microsoft website. at the moment I have removed the PCIe riser and reinstalling the windows. Lets whats gonna happen. I will keep you updated, thank you.
 

Lutfij

Titan
Moderator
I have Cooler Master. RM 850 Fully Moduler ATX Power Supply
Coolermaster never made an RM 850 unit, Corsair did.

Install the OS without the www connected, once in the OS GUI after a successful OS install, manually install all relevant drivers for your platform, in an elevated command. In order to do that, you will need to download all necessary drivers onto a pen drive.
 

ASK THE COMMUNITY