Question New build won’t turn on anymore ?

scrippie10

Distinguished
Oct 11, 2012
46
1
18,535
0
Hi all,

I recently built a PC - turned on the first couple of times but was running into an issue where it wouldn’t let me launch the bios. Basically was stuck on a screen with the asus logo and a prompt asking me to press F2 or Del to launch the bios. I was later informed that since my mobo likely had an older BIOS that wasn’t compatible with my cpu. The next day as I was getting ready to install the latest BIOS but the pc would simply not turn on anymore. I just hear a clicking sound when I press the power button.

I’ve since unplugged and replugged everything have tried just leaving the mobo, 24 pin and AIO plugged nothing. I’ve removed everything and built the pc again still nothing, I’ve also tried building it outside the case but it just won’t budge. Have checked the cpu pins, removed and reapplied thermal paste. Tried using one stick of ram, switching them up etc. Ran the PSUs fan test and it worked so I assume it’s fine. Basically browsed a number of threads and tried what worked for others with similar issues but it seems I’ve ran into a wall. Please help!

These are my specs
CPU: Ryzen 5900
Rtx 3090
Mobo: Asus Crosshair VIII Formula X570
Ram: Corsair 32 gb 4266 MHz
PSU: Corsair HX1200i Platinum
M.2: 970 Evo plus 2 tb and Adata sx8200 pro

I will say one out of every 30-40 attempts works, meaning the PC has turned on just not consistently.
 

ASK THE COMMUNITY

TRENDING THREADS