Question New build won’t turn on except for motherboard RGB lighting ?

Jan 5, 2021
1
0
10
0
Hello all, so I decided to undergo the task of building my first PC over new year’s eve and i’ve finished - or so I thought.

When I went to turn my PC on, the only thing that lit up was the RGB on my motherboard (Asus ROG Strix B550-F Gaming Wifi). No fans, nothing else turned on except the RGB on my motherboard and the RGB on my keyboard flickered. No debug leds lit up on my motherboard to help debug the problem as the thing wouldn’t turn on. I think that it is a good sign that power is running through the system if the LEDs are on.

Here are the specs:

CPU: AMD Ryzen 5 3600

CPU Cooler: Corsair H100i RGB Platinum

Motherboard: Asus ROG Strix B550-F Gaming Wifi

Memory: Corsair Vengeance RGB Pro 16GB (2x8) DDR4-3200 CL16 Memory

Storage: ADATA XPG SX8200 Pro 1 TB

Video Card: Gigabyte Gaming OC 5600xt

Case: Phanteks P400A Digital ATX Mid Tower Case

Power Supply: Corsair CXM 550 W 80+ Bronze Certified Semi-modular
To troubleshoot, so far I have re-done the front panel connectors multiple times (my case only came with three which are the HDD LED, Reset SW, and Power SW), re-mounted the motherboard, made sure all of my power cables are connected, and re-plugged in the power to the PSU. What I plan on doing next is testing if the PC turns on without the power switch (in case of a faulty power button), and plug in the 24pin, 8pin, and PCIE cables without the cable extensions that I purchased (Cable Mod).

Some other input I have gotten is to test the PSU using the paperclip method, and to replug in all the PSU power cables/ check cables.

I’m not sure what the problem exactly is and I would love your input. Please help me out and I’ll respond to all questions. I also plan on attempting these fixes later today so I’ll edit the post to show what did/didn’t work.
 

ASK THE COMMUNITY

TRENDING THREADS