Question New build won't boot (no display*), Ryzen 3600 ASUS x470 Prime Pro

ThePixelPerson

Reputable
Feb 26, 2015
67
0
4,640
1
I recently built my new rig:
Asus prime x470 pro motherboard
AMD Ryzen 5 3600 processor
16 GB ballistic sport ram 2666Mhz
550W gold EVGA power supply
Sapphire Amd rx590 8gb graphics card
+2 HDD and an SSD

I built the whole thing in about and hour and a half, and plugged it into my power strip. Motherboard lights lit up, graphics card and keyboard+mouse lit up. Pressed the power button and all the fans turned on properly and heard the HDD spin up. These are all signs that the MOBO and power supply are functioning at least somewhat properly.... but no display. I gave it about 10 minutes then turned it off with a long press of the power button. I switched the hdmi ports on the graphics card and tried again. Still no display. I tried reseating the ram, putting the ram in different slots, I re-wired the whole thing, tried with no USB peripherals, still no display. I'm also sure I seated the cpu properly so I'm at a loss right now. If anyone knowledgeable on Ryzen 3rd gen processors and x470 mobo (especially asus) can give me any advice I'd be grateful. I've also heard that the x470 pro was supposed to be compatible with 3rd gen Ryzen out of the box so I don't think that's it, and if it is I'm not quite sure how I'm gonna update the bios since I don't have an 1st or 2nd gen Ryzen processor at my disposal to boot up the rig and hit it with a bios update that way. IF the bios IS the issue is there any way to update it with USB, with or without the CPU in the mobo? So many questions. Btw it's notable that when I turned the system on the HDD light never blinked and the reset button refused to function even though I reseated the case io connectors 3 times and even tried it with the asus io connector adapter. Plz help
 
Jul 26, 2019
1
0
10
0
I'm having this issue as well with my b450 tomahawk and ryzen 5 3600, did you find a solution?

I did the bios update on mine using a flash drive, it may or may not have worked...?
 

ASK THE COMMUNITY

TRENDING THREADS