Sep 22, 2021
I assembled a new computer yesterday and it won't turn on. Meaning, I hit the power button, case/cpu fans won't turn, no beeps, no lights. I have everything secured in place and the power supply is good (the PS is less than 4 months old and I removed it from my previous build). I have tried 2 working PS and the same thing has happened. I even put the PS back onto my older rig and had to use that to get the work done. I have tried to jump it without the case power button (just in case the wiring in the case was bad), but still didn't have anything.. I haven't ever had this happen before, I have always at least heard beeps, lights to signal an error, but this time there isn't anything.

AMD Ryzen 5600X (using the stock wraith cooler)
MSI MAG B550 Tomahawk
Corsair Vengeance LPX 16GB DDR4 3200MHz
Zalman S3 ATX Mid Tower Case (3 preinstalled fans)

These are the only new components. The GPU is only a few months old also and works in my old rig. (I am not at home, so can't give exact model of GPU)

I am at a loss of what to do other than take it to a computer store to have them tell me what is wrong. Could it just be a bad motherboard (I have had a bad motherboard before and it still turned things on though with the error codes)



I think the signs point to a bad motherboard.
You may have already done this.....but I would double check all the connections again.
....and I would double check that the "power on pins" are correct (the ones you are jumping)
....and I would try to power on with the bare minimum to boot.


Mar 24, 2019
try attempting to run the system outside of the cabinet. Remove the cabinet from the equation. Try plugging the PSU to another mains power socket.
If that does not help RMA the board.