New build worked for a couple hours now none of the rear and front i/o ports work and no signal from graphics card.

noisetankjgr

Prominent
Oct 9, 2017
2
0
510
0
CPU: Intel - Core i7-7700K 4.2GHz
CPU Cooler: Noctua - NH-U12S
Motherboard: ASRock - Z270 Extreme4 ATX LGA1151
Memory: Corsair - Vengeance LPX 16GB (2 x 8GB) DDR4-3200
Storage: Samsung - 850 EVO-Series 500GB 2.5" Solid State Drive
Storage: Samsung - 850 EVO-Series 1TB 2.5" Solid State Drive
Video Card: Asus - GeForce GTX 1080 Ti 11GB STRIX GAMING
Case: Phanteks - Enthoo Pro ATX Full Tower Case
Power Supply: EVGA - SuperNOVA G2 750W 80+ Gold Certified Fully-Modular ATX
Operating System: Microsoft - Windows 10 Home

New build was working fine for a couple hours last night but when I went to do a reset nothing came on the monitor and none of my peripherals plugged into the rear i/0 were getting power. The power button on the case still works and all the fans/lights turn on but nothing plugged into the rear or front i/o gets power and nothing comes up on the monitor whether plugged in thru graphics card or directly into motherboard.

I have tried shorting the cmos, removing the motherboard battery for 10 minutes then reinserting it, removing the graphics card, hard drives, ram, reconnecting all power plugs, and connecting directly to the motherboard with hdmi.
 

Similar threads