Question new build

Feb 25, 2021
6
0
10
0
I am doing a new build. I bought an asus tuff x570plus motherboard I have installed it it turns on the dvd thing works and the hard drive works. it has ram like 8tb plus one of those other little stick things. I put in a cpu the fan on it comes on. When I try to get a screen I get nothing I hooked and HDMI cable to it and its not sending so I cant do any updates or installs because I cant see a screen. HEeeeeeeeeeeeeeeeeeeeeelp
 
Feb 25, 2021
6
0
10
0
Please list full pc spec
o good lord I dont know what these are called let me see a ryzen 5 3600 a tuff gaming x570 plus motherboard some other add on things like extra usb a other kind of memory stick 2 ram unit things a dvd drive and a 2 tb harddrive I think im very knew to this and just have bought what they say works with it have not bought a graphis card yet waiting to get the money then I have key board wireless sorry not real smart at this stuff wont be doin this again.
 

ChangeinPortland

Prominent
Sep 9, 2019
32
9
535
0
I think if trying to list your parts is too much for you, fixing this is WAY too big a task for you. Take it to a repair shop and see what they want to get it going.
 
Feb 25, 2021
6
0
10
0
I think if trying to list your parts is too much for you, fixing this is WAY too big a task for you. Take it to a repair shop and see what they want to get it going.
Your probably right im 71 and my memory isnt what it used to be. I normally dont do these types of things at all. Much less understand what all of these parts do.
 
Feb 25, 2021
6
0
10
0
Ok you need a graphics card, that cpu has no integrated graphics. You won’t get any display without a gpu.

What exact RAM and PSU do you have? It’s important to know what parts you have.
thank you very much it has 8 gigs of ram I dont know what or I haven't bought a PSU I dont know what it is.
 
Feb 25, 2021
6
0
10
0
I got a graphics card gforce gtx 970 nothing on screen its a new build the hard drive may have windows whatever on it but thats it everything else is new. Thanks
 

Ds_Tech

Great
Jan 25, 2021
176
13
95
2
  1. In which slot you have installed gpu it should be first slot near to cpu socket.
  2. And HDMi cable connect to gpu hdmi, not to motherboard hdmi.
  3. remove all ssd hdd then check and install only one stick ram in last grey slot and if 2 sticks of ram in grey slot only.
  4. try remove cmos battery and install battery again.
 

ASK THE COMMUNITY