Question New Built / DRAM B1 and B2 not working?

Dec 2, 2020
2
0
10
0
Hey guys, i would appreciate all input on this.

Built a PC last night, everything is working perfectly fine, except the Ram B1 and B2 slots, when i put my ram sticks in them, the rgb lights up, but i get a yellow flash followed by a red flash on my motherboard.

please note, Ram A1 and A2 work fine and i can boot up. But when i insert Ram in B1 and 2, it seems to do the yellow to red light on motherboard.

all 4 Ram sticks are working as i have tested them, done CMOS as well to see if any luck and i am certain my motherboard supports 64GB / 4 ram sticks.

i just want to know what the problem could be and if anyone can shed a light on this matter

Also, i have tried the method of putting ram in A1 and B1 and A2 and B2, but the B ports don’t seem to pick up the ram, only the RGB light comes on meaning they get power

PC Specs:
i9 10900k
3090 Aorus Master
64GB Corsair Vengeance 3200 ( only 32gb works in A ports, B ports don’t work)
Asus H470 TUF Pro Wifi
850w Aorus PSU
Floe Riing 280 CPU Cooler (have double checked, its not too tight on the mobo)

To sum it up, 32GB ram works fine (2 sticks in A1 and 2) but B1 and 2 there’s only RGB that comes on but no response, shows up a yellow light on motherboard followed by a red and its a loop, no turning on no bios etc, have tried CMOS and resorting and re inserting the ram, to make sure they all click and stuff.
 

white.a.drew

Reputable
Oct 14, 2017
1,379
95
5,640
79
Hey guys, i would appreciate all input on this.

Built a PC last night, everything is working perfectly fine, except the Ram B1 and B2 slots, when i put my ram sticks in them, the rgb lights up, but i get a yellow flash followed by a red flash on my motherboard.

please note, Ram A1 and A2 work fine and i can boot up. But when i insert Ram in B1 and 2, it seems to do the yellow to red light on motherboard.

all 4 Ram sticks are working as i have tested them, done CMOS as well to see if any luck and i am certain my motherboard supports 64GB / 4 ram sticks.

i just want to know what the problem could be and if anyone can shed a light on this matter

Also, i have tried the method of putting ram in A1 and B1 and A2 and B2, but the B ports don’t seem to pick up the ram, only the RGB light comes on meaning they get power

PC Specs:
i9 10900k
3090 Aorus Master
64GB Corsair Vengeance 3200 ( only 32gb works in A ports, B ports don’t work)
Asus H470 TUF Pro Wifi
850w Aorus PSU
Floe Riing 280 CPU Cooler (have double checked, its not too tight on the mobo)

To sum it up, 32GB ram works fine (2 sticks in A1 and 2) but B1 and 2 there’s only RGB that comes on but no response, shows up a yellow light on motherboard followed by a red and its a loop, no turning on no bios etc, have tried CMOS and resorting and re inserting the ram, to make sure they all click and stuff.
Dram controller is dead, or cpu is improperly seated so not reading dram channles right
 

ASK THE COMMUNITY

TRENDING THREADS