New Comp-NTLDR Is Missing-Harddisk Not Found-WTF?!



I ordered this computer from
AMD T-Bird 1400MHz 266MHz FSB
512MB PC2400 DDR SDRAM CAS 2 (two 256MB sticks)
IBM Deskstar 40GB ATA100 7200RPM
Pioneer DVD-106S
Gainward Cardex GeForce 3
SoundBlaster Live! X-Gamer 5.1
Windows 2000 Pro
case, floppy, mouse, keyboard, speakers, etc.

Well, I get it home, plug everything in, turn it on...

Boots to desktop.

Well everything is okay except that I'm a MORON and I had the keyboard and mouse in the wrong !@#$ing PS/2 ports (they were each in the other's port)! I feel so stupid! I was just used to plugging them into this old thing, where they are opposite. Anyway, I thought it was just frozen because the keyboard and mouse "weren't working." So I hit the power button but a message saying something about nVidia popped up (proving that it wasn't frozen). I held the power button as I tried to read it but the system shut down before I could gather what the message said. So I just switched the mouse and keyboard and thought, "No big deal, right?"

WRONG! I hit the powerbutton again and am greeted with a lovely "NTLDR is missing. Hit ctrl+alt+del to restart." What in the hell? Restart and recieve the same error.

So I got on the 'net on this old thing and looked up "NTLDR is missing." I gathered that is happens for a couple of reasons. 1. You have a floppy or CD in one of the drives. Nope. 2. You are dual-booting Win9x and Win2k. Nope, neither of those are me. I found something about booting from the Win2k Pro CD and hitting "R" for repair so I went into the BIOS and set it to boot from CD-ROM. I restarted and when it said "hit a key to boot from CD-ROM," or whatever, so I did and the Win2k setup stuff came up. I hit "R" for repair but it said it couldn't find a harddrisk and then rebooted. I then tried the same thing but hit ENTER to "Setup Win2k now," or whatever, and it gave me the same error.

I thought maybe the harddrive wasn't connected right so I opened the case. The DVD drive is connected to IDE 1 and the harddrive is connected to IDE 3. I checked all the IDE cables and they seemed to be connected correctly. Still didn't work.

In the BIOS the boot sequence is set to Floppy, IDE0, CDR0M.

This computer is a crappy little AMD K6 200MHz, 64MB RAM running Windows 98, incase it could be used to help.

EnvisionCS isn't open 'till Tuesday and I really need some help with this.

Thanks a lot in advance!


Oops! I forgot to mention the motherboard is a GigaByte GA-7DXR. I was tired, sorry.


Mar 25, 2001
My first reaction was to ask whether you were able to see the harddrive on BIOS startup screen, tried to troubleshoot using boot from floppy to recognize the file system.
I won't take up any more of your time, being too wordy.
There're some more articles, as you understand, not the exact match, but provide some clues on your problem and how to troubleshoot it.

<A HREF="" target="_new">"NTLDR Is Missing" Error Message When You Upgrade or Install Over Windows 95 or Windows 98</A>

<A HREF="" target="_new">Windows NT Boot Problem: Kernel File Is Missing From the Disk


No, the harddrive does not show up in the BIOS. Only the DVD drive on IDE1. I moved the DVD to IDE2 and the harddrive to IDE1 and it did show up in the BIOS, but I get the error "Ultra100 BIOS is not installed because there are no drives attached" and then the infamous "NTLDR is missing." =(