Question New CPU causing ports to not work?

Jan 22, 2022
2
0
10
0
I got an upgrade from my ryzen 5 2600x to a ryzen 5600x today. However, once I had put the new CPU into my motherboard, none of my ports on the side of my computer worked(Most notably my USB and HDMI). Any help would be extremely appreciated!
Things I have tried:
Testing each ram stick
Tested old CPU(still worked)
Checked the new CPU prongs(I think they are ok)

Specs:
MB: Rog Strix x470-f Version: 5406 11/13/2019
CPU(Before): Ryzen(5) 2600x
CPU(After): Ryzen(5) 5600x
GPU: Gigabyte gtx 1660ti
Ram: Corsair 4x8gb dimm ddr4 3200mhz
PSU: EVGA 750 watt Supernova
Storage: 1x500 gb Samsung 970 evo + 1x2tb DVD/CD drive

Not 100% if flashing my bios or updating my bios would help but if it will I'll look into it.
 
Last edited:
I got an upgrade from my ryzen 5 2600x to a ryzen 5600x today. However, once I had put the new CPU into my motherboard, none of my ports on the side of my computer worked(Most notably my USB and HDMI). Any help would be extremely appreciated!
Things I have tried:
Testing each ram stick
Tested old CPU(still worked)
Checked the new CPU prongs(I think they are ok)

Specs:
MB: Rog Strix x470-f Version: 5406 11/13/2019
CPU(Before): Ryzen(5) 2600x
CPU(After): Ryzen(5) 5600x
GPU: Gigabyte gtx 1660ti
Ram: Corsair 4x8gb dimm ddr4 3200mhz
PSU: EVGA 750 watt Supernova
Storage: 1x500 gb Samsung 970 evo + 1x2tb DVD/CD drive

Not 100% if flashing my bios or updating my bios would help but if it will I'll look into it.
Yes, update BIOS to the very latest for Ryzen 5000. It fixes a number of issues including USB port dropouts.

Also be sure to reset CMOS for the new CPU...and again after updating BIOS.
 

ASK THE COMMUNITY

TRENDING THREADS