Aly22

Distinguished
Nov 7, 2013
17
0
18,510
0
Hi Everyone,

I got an lg34wn750 display, but it doesn't want to connect to my Geforce GTX960m, on my Asus ROG Strix gl552vw laptop. I know that it doesn't support g-sync, but it would be nice to have it connected to my main GPU. Because I want it to run on 60 Hz and not black-out sometimes. here are some screenshots:

View: https://imgur.com/a/VtYny5E


Any answers would be appreciated. :)
 
There is no separate port to connect an external monitor directly to the discrete gpu.
You use the discrete gpu by default when plugged in.
The laptop drivers manage the connection.
The nvidia control panel will give you options to use it or not.
By default, the HD530 will be used when on battery to save battery run time.
If you play games, play plugged in.
 

Krotow

Commendable
Oct 2, 2019
1,010
248
1,590
15
Connect laptop to monitor with HDMI cable. Then use display switch function under laptop Fn key. Or in Windows display settings set monitor as first display.

By the way G-Sync works only over DisplayPort. If this laptop have only HDMI output then you are out of luck to have variable refresh rate.
 

Aly22

Distinguished
Nov 7, 2013
17
0
18,510
0
There is no separate port to connect an external monitor directly to the discrete gpu.
You use the discrete gpu by default when plugged in.
The laptop drivers manage the connection.
The nvidia control panel will give you options to use it or not.
By default, the HD530 will be used when on battery to save battery run time.
If you play games, play plugged in.
I don't understand 😅. Could you please clarify the thing about the nvidia control panel? Because it doesn't show up for me just the 3d settings.
 

Aly22

Distinguished
Nov 7, 2013
17
0
18,510
0
Hi Everyone,

I got an lg34wn750 display, but it doesn't want to connect to my Geforce GTX960m, on my Asus ROG Strix gl553vw laptop. I know that it doesn't support g-sync, but it would be nice to have it connected to my Geforce GPU. Because I want it to run on 60 Hz and not black-out the background sometimes. Here are some screenshots of what I've tried so far:

View: https://imgur.com/a/2l83pLP

I also tried to set it in BIOS, but there was no option to disable the integrated graphics card.

Any answer would be appreciated. :)

It says on the first screenshot in the upper-right corner:
"The computer can not project to another display. Please refresh the display driver, or try another GPU"
 

Akshay_38

Reputable
Jan 13, 2017
10
2
4,515
0
GPU related problem in short the drivers , somehow your integrated graphics drivers on the priority , idk how laptops graphics works but mostly they work on some 'sharing kind' of workload , you start intensive gpu work then your 960m takes command otherwise intel takes the less intensive tasks , i think you should completely uninstall the drivers and install 'geforce experience' or driver auto-detector to install proper drivers right from the start ,you can also try with 'ONLY intel drivers to project screen ( without nvidia drivers atall), btw you don't even need to go on nvidia control panel ,you can project and tweak settings from right click on the desktop> display which is attached on the image ,https://www.google.com/search?q=screen+display+settings&client=ms-android-oppo&prmd=vni&sxsrf=ALeKk01yc-p8FGP650owZ9-OPMyhl_sTKg:1616878177354&source=lnms&tbm=isch&sa=X&ved=2ahUKEwjuxp_LrNHvAhU6xzgGHe3dCVEQ_AUoA3oECAIQAw&biw=360&bih=672&dpr=3#imgrc=1OGD5SPZsaHEfM
 

ASK THE COMMUNITY

TRENDING THREADS