Question New EVGA PSU sparked?

RyanDotDot

Honorable
Nov 18, 2015
29
0
10,530
0
New EVGA PSU sparked?

Hello!

I just installed a new EVGA PSU into my main computer today and after doing some cable management I tested it out in my living room, everything spun up perfectly! After carrying it to my game room and getting it setup I tried powering it on but it blinked all RGB / power and then turned off right after. So I switched everything off, re-seated the power cable, and went to turn it on again but this time i seen a small spark inside the PSU case. I again powered everything off and rushed it to the living room to inspect it. There was no smell and seemingly no damage. I carefully inspected all of my connections and re-seated every cable to make sure they were completely in.

It booted up perfectly fine after that, no sparks, no powering down. I carefully brought it back to the game room and now it’s working fine!
In the end of this mini-heart attack I guess my questions are:
  1. What could of caused this kinda spark?
  2. If everything is seemingly fine should I be concerned?
It has a 10 year warranty but I’d still like to be cautious if needed.

Thank you for any help/tips!
 

RyanDotDot

Honorable
Nov 18, 2015
29
0
10,530
0
It was probably all the static electricity discharged from carrying your computer all over the house. You got to see in person the " spark" that can ruin your whole pc setup if not grounded properly. Buy a lottery ticket today is your lucky day.
Thank you for the quick response!
Would you recommend that I RMA this one and get a new one?

Everything seems to be 100% and performance is fine.
 

ASK THE COMMUNITY