News New Firmware Will Restore WD Black SN850's Performance On AMD X570 Chipset

plateLunch

Honorable
Mar 31, 2017
61
9
10,535
0
So does anyone understand the PCIe bus enough to make sense of WD's explanation? Sounds incomplete. Who is setting the 128 byte MPS? Is the packet size negotiated and the SN850 wasn't doing that? Just curious.
 
Jun 22, 2021
2
1
10
0
So does anyone understand the PCIe bus enough to make sense of WD's explanation? Sounds incomplete. Who is setting the 128 byte MPS? Is the packet size negotiated and the SN850 wasn't doing that? Just curious.


I don't know enough to provide you with a technical explanation but i can tell you as someone who has recently purchased an X570 board..the GB aorus Master and found this problem pretty much straight away to tell you what the cause is

the problem is to do with components on the board The lowest max payload speed on the bus will restrict everything else on the same bus to that speed. In my instance the WiFi adaptor's max payload speed is 128. which means the NVME controller on the board along with my capture card on the PCIE 4.0 16 x4 is also being restricted to 128 bytes
Unfortunately the BIOS doesn't let you disable the WiFi adaptor so i had no way to resolve or at least alieviate the problem

I ran into some people on another forum who had a similar issue and they didn't know what was going on, i explained that this was my issue and to check their max payload speed. the OP had a diofferent board, but the same problem which was traced to the titan thunderbolt port's max payload speed being 128 bytes. they were able to disable the port in the bios and the next component up was 256 bytes. they got a performance increase which showed that the max payload speed was indeed the culprit.
 
Reactions: Soaptrail

SampsonJackson

Prominent
Mar 2, 2020
2
0
510
0
So does anyone understand the PCIe bus enough to make sense of WD's explanation? Sounds incomplete. Who is setting the 128 byte MPS? Is the packet size negotiated and the SN850 wasn't doing that? Just curious.
MPS, Maximum Payload Size, dictates the size of the individual data packets on PCIe (TLP; payload). Simply put, a larger payload size increases efficiency of the PCIe link because you can transmit more data per "chunk", and reduce link overhead (requests, acknowledgement, etc).

Here is an excellent overview of MPS, and the relation with link efficiency (pdf warning!):

https://www.xilinx.com/support/documentation/white_papers/wp350.pdf

Thst said, the difference between MPS=256B vs. 128B is about 200-300MB/s, when the link is at 100% utilization. It makes no difference to throughput, from link point of view, until you approach link saturation.

WD fixed it fast! Nice work!

(Oops, didn't mean to reply to post!) :)
 

djwagz

Prominent
Feb 9, 2021
26
0
530
0
I good a great deal on the sn850 and was going to install in 2nd m.2 drive which works off chipset. After hearing all the horror stories about it's slow and they could not find the drive. wouldn't show up after cold boot etc., I cancelled the order. Does anyone know if the new update actually works with 570 mobos? I could always install it in the main pcu slot, but my inland premium in there with os and working awesome. So really looking but 2 TB using 2nd m.2 slot off chipset. I know I won't get the speed using this slot. The sn850 is still available but many of the issues were people using on 2nd m.2 chipset. Anyone fix this issue with update? I can get the sn850 2TB for $230 and the reliable know will work evo pluse is also $230. I know part of it is turning off some devices to get up to 256mb on that channel. Does the new update fix this, or just go with samsung because it will work?
 
Last edited:
Jun 22, 2021
2
1
10
0
it works in terms that it fixes the main issue which was the write speed, however there is still an issue with the read speed. I turned off the wifi adaptor on my MB which is an Aorus X570 master rev 1.2 which was the factor limiting the MPS to 128. After the update turning this on or off had no noticable impact on the write speed but it still caused a reduction in the read speed, it wasn't as impacting a diference as the write speed issue before the update but the fact is there is still a difference.

I've been back and forth to WD support staff about this, they had their engineers investigate it and said it was working as expected so they weren't going to do anything about it. i've got the crystaldisk reports somewhere i can dig them out if you want.

EDIT i think i found the report and it's about 300 MB/s loss which would tie in with what SampsonJackson said

If i'd had known there was an issue at the time i would have just bought samsung, never had a problem with those.
 

ASK THE COMMUNITY