New G-sync monitor stutter??

_dawn_chorus_

Respectable
Aug 30, 2017
313
0
1,810
7
I just got the LG 32gk850g-b and set it up and much to my dismay my games stutter more than ever..In fact everything does.

This monitor is 3 firsts for me; g-sync, 144hz, & 1440p.

So it stutters in games, and even as I type this it has a little "cha-chunk" stutter every little bit. If I rotate the mouse in a circle about every 5-7 seconds it stutters..
In games I am staying over 100fps at all times, but like I said it's even choppy while browsing or just opening folders.
I am using the display port cable currently
So what am I missing?? My system specs are:

i7-7700
16gb DDR4 2133
Msi B250 Mortar Mobo
EVGA 1080 SC2
Corsair RM550x
2 Samsung 850 evo 500gb (both about 70%full)

So what am I missing??
 

boju

Champion
It's difficult to say what causes stutters in most cases, could be Windows, drivers or game itself. The list of things to try can be extensive but i guess need to try them all.

I've been using a Gsync monitor for couple years now and very pleased with it. It's an Acer XB270HU and first for me as well going from 60 to 144Hz. Gsync's main goal is to eliminate tearing, use of Vsync, avoid input lag and improve motion with variable frame rates as you're aware.

It's all up to the game's optimisation and how it uses the system and also how Windows behaves in the background.

Games i've played that are generally smooth but not always as with 3Dmark and source games. Those games are Farcry 4, 5 and Primal, Ghost Recon, GTA5, Dying Light. They are generally smooth but how things are loaded in and out of ram, Vram and HDD/SSD, there can be quite a bit going on so i just accept that some games aren't going to be 100% smooth all the time, depends how they've been developed and optimised for PC. Just my experience with games. I know my system is lean and running well for it's age. 2600k 4.5, 16GB ram, 1080Ti and SSD, Win7.

Depends on your issue how bad the stutters are could be the result of Windows settings, drivers, or game/game settings.

We'll go through some of the usual rounds of troubleshooting and suggestions for you to try.

First though, run 3Dmark firestrike or timespy and see if you get any stutters. Basic edition download bottom of page. https://benchmarks.ul.com/3dmark

What games have you tried that stutters in? Can you try Halflife 2, Left 4 dead or Portal?

----

Things to try: Assuming you're on Win10 with that system?

Windows and Nvidia power plans are set for performance.

Make sure game bar and xbox dvr has been turned off. Xbox dvr (on by default) recording app records your game play automatically. Another feature of game bar is fullscreen optimisation which is like windowed borderless fullscreen. Can mess with some games and the option for it can be found under the compatibility tab of the game's exe or shortcut.

Run malware/virus scans. Since you're running at a higher frame rate now you need as much cpu power as you can get. 60Hz might not have been as noticeable so make sure the cpu is sitting at or near idle usage before playing games.

Turn off share Windows updates to strangers. Shouldn't be an issue but i'd turn that off anyway.

Reinstall gpu drivers by using display driver uninstaller first in safemode. https://www.wagnardsoft.com/

Install Chipset drivers for your motherboard if haven't from the vendor's website.

Last for now, don't let Geforce Experience optimise your games, usually gets it wrong and set things too high or use of Nvidia's gamework features that can be buggy in games that use it. Since using 1440p resolution, might find don't really need antialiasing anymore either and squeeze more performance.

 

_dawn_chorus_

Respectable
Aug 30, 2017
313
0
1,810
7


Temps are fine, low 30's, was on the computer all day on my old 1080p 60hz, it's just on this new monitor.
 

_dawn_chorus_

Respectable
Aug 30, 2017
313
0
1,810
7


Well, I feel like a fool, a simple restart seems to have fixed the stutter.
Although in some games like metro 2033 and resident evil 7 I am getting like 250 - 370 fps and its causing some massive coil whine. Should I set a frame rate target for the gpu, or will that cause conflicts with g-sync?
 

boju

Champion
The displayport cable you're using came with the monitor?

Can't find anything posts regarding any issues. Have you tried reinstalling or updating gpu drivers and try with or without monitor driver?


Edit. Nevermind. Shouldn't be connecting hot plugs while the pc is on if that's what you did. Not that it would harm anything but might have not engaged/ initialised Gsync properly
 

_dawn_chorus_

Respectable
Aug 30, 2017
313
0
1,810
7


Yeah I did do that at first, after a restart the stutter was fixed.
 

_dawn_chorus_

Respectable
Aug 30, 2017
313
0
1,810
7


It looked pretty good, a little black smearing on the darker color, nothing on the light.
 

_dawn_chorus_

Respectable
Aug 30, 2017
313
0
1,810
7


So the stutter is back but just in games...the only thing that changed was it went to sleep. Since I did initially plug it in hot, how can I reinstall the monitor drivers?
 

boju

Champion
Probably wont make any difference installing monitor driver. Only suggested it originally based on nature of your original problem before seeing your reply describing what you did to fix.

If you want to try drivers can grab them from LG's site.

What kind of lag are you experiencing? It could be different issue not relating to the monitor.
 

_dawn_chorus_

Respectable
Aug 30, 2017
313
0
1,810
7


Yeah it wasn't drivers... I have been pulling my hair out trying every possible combination of things on and off in game and out of game. Even if I turn g-sync off, set it to 60hz and put in game v-sync on it stutters. When I plug in my old monitor (1080p 60hz) it runs smooth again. Albeit noticeably blurry.

I have found there is a handful of people who have this issue but I cannot find a solution, just threads that go on and on.

Since I have never seen a g-ysnc monitor in action in real life before I have no reference point, but this cannot be what everyone refers to as "buttery smooth".

This is what I am seeing although not quite as bad:
https://www.youtube.com/watch?v=-vhBK1wZrfs
 

boju

Champion
It's difficult to say what causes stutters in most cases, could be Windows, drivers or game itself. The list of things to try can be extensive but i guess need to try them all.

I've been using a Gsync monitor for couple years now and very pleased with it. It's an Acer XB270HU and first for me as well going from 60 to 144Hz. Gsync's main goal is to eliminate tearing, use of Vsync, avoid input lag and improve motion with variable frame rates as you're aware.

It's all up to the game's optimisation and how it uses the system and also how Windows behaves in the background.

Games i've played that are generally smooth but not always as with 3Dmark and source games. Those games are Farcry 4, 5 and Primal, Ghost Recon, GTA5, Dying Light. They are generally smooth but how things are loaded in and out of ram, Vram and HDD/SSD, there can be quite a bit going on so i just accept that some games aren't going to be 100% smooth all the time, depends how they've been developed and optimised for PC. Just my experience with games. I know my system is lean and running well for it's age. 2600k 4.5, 16GB ram, 1080Ti and SSD, Win7.

Depends on your issue how bad the stutters are could be the result of Windows settings, drivers, or game/game settings.

We'll go through some of the usual rounds of troubleshooting and suggestions for you to try.

First though, run 3Dmark firestrike or timespy and see if you get any stutters. Basic edition download bottom of page. https://benchmarks.ul.com/3dmark

What games have you tried that stutters in? Can you try Halflife 2, Left 4 dead or Portal?

----

Things to try: Assuming you're on Win10 with that system?

Windows and Nvidia power plans are set for performance.

Make sure game bar and xbox dvr has been turned off. Xbox dvr (on by default) recording app records your game play automatically. Another feature of game bar is fullscreen optimisation which is like windowed borderless fullscreen. Can mess with some games and the option for it can be found under the compatibility tab of the game's exe or shortcut.

Run malware/virus scans. Since you're running at a higher frame rate now you need as much cpu power as you can get. 60Hz might not have been as noticeable so make sure the cpu is sitting at or near idle usage before playing games.

Turn off share Windows updates to strangers. Shouldn't be an issue but i'd turn that off anyway.

Reinstall gpu drivers by using display driver uninstaller first in safemode. https://www.wagnardsoft.com/

Install Chipset drivers for your motherboard if haven't from the vendor's website.

Last for now, don't let Geforce Experience optimise your games, usually gets it wrong and set things too high or use of Nvidia's gamework features that can be buggy in games that use it. Since using 1440p resolution, might find don't really need antialiasing anymore either and squeeze more performance.

 

boju

Champion
What drivers are you on?

Funnily enough i just updated gpu driver to 397.31 and something weird happened. Games ran fine but after exiting however, browsing, dragging windows in circles was really choppy and typing was very slow. Thats never happened before. Went back to 391.35 and all was well again. Shame because there was an increase in fps for me with 97 driver :\ oh well.

Thought id mention it just in case you're using 397.31 too that the driver if somehow related to your problem.
 

_dawn_chorus_

Respectable
Aug 30, 2017
313
0
1,810
7


Thanks for all the suggestions boju! Just wanted to say I am gonna try all these things later today and see what happens. I'll get back soon.
 

_dawn_chorus_

Respectable
Aug 30, 2017
313
0
1,810
7


Hey boju, apologies for the late reply, some health issues kept me down for this past week. Anyhow it seems to be running pretty smooth now in most titles for the most part.

Runs flawlessly or very near to it:
Left 4 Dead 2
Dying Light
FarCry4
The Forest
Metro: 2033 Redux
Vermintide 2

Mostly Flawless but with occasional stutter, probably just because they are super demanding?:
The Witcher 3
Rise of the Tomb Raider
Evil Within 2

Potato level of stutter: (looks drastically better on my 60hz with v-sync, almost unplayable on new monitor)
Dishonored 2 - Constant small stutter in both dishonored titles
Dishonored: Death of the Outsider
Wolfenstein: T.N.C - near constant stutter, wavy ripple like tearing

- 3Dmark ran very smooth no noticeable stutter, so I am assuming a lot of the issue is game optimization sadly. The Dishonored series are some of my favorite and most played games so thats a bummer. I did find a steam thread about optimizing settings for D2 to eliminate this very issue so I will have to try that soon.

- Windows Power Plan is set to high performance, I changed Nvidias back to auto because on performance mode it keeps my GPU fired up to its base clock 100% of the time, even while browsing.

- I have no game bar or xbox anything installed except the drivers for the xbox1 controller.

- No virus or Malware, CPU runs about 3-4% with apps closed. (largely cortana)

- No "share info" settings of any type are on

- I have not yet tried reinstalling the GPU drivers but may if the problem gets worse again.

- Chipset drivers installed on first boot up after build

- Uninstalled Geforce experience a couple months ago.

Ultimately after changing several settings back and forth in the Nvidia control panel>3D settings I seem to have found a balance. A few settings I was turning on and off and their current settings:

Maximun pre-rendered frames - 1
Power Management Mode - Adaptive
Preferred Refresh Rate - Highest Available
Threaded Optimization - On
Triple Buffering - On
Vertical Sync - Use the 3D Application Setting

I think overall after switching back and forth, the remaining minor stutter is just reality falling short of my expectations. I think I heard "buttery smooth" said about G-sync enough times without a proper context or side by side comparison that I expected it to be perfect.
I can notice a small bit of stutter now on the 60hz but it is masked by the blur while panning. The new larger clearer faster screen just sort of emphasizes the imperfections of games. None the less, it games look astounding and I am enjoying it massively overall. A real shame about what seems to be every Bethesda title I play having the most actual jitter problem. I will have to further try adjusting in game settings on those titles.

Lastly, how do you find and uninstall/reinstall the specific G-sync driver 397.31? I might want to try that , or need to with future updates.


 

boju

Champion


All good, hope you're feeling better :) I put my answers in bald in the quote of yours instead of messing around with quote codes.

Couple other notes. If it turns out you do have game bar, you'll see the options to disable various things. Also some games don't like borderless windowed mode or the other name for it is fullscreen optimisation. For Triple buffering to work need to be running with fullscreen optimisation - on by default. For games that don't run well in borderless windowed, manually turn off fullscreen optimisation under the compatibility tab of the game's exe or shortcut.
 

ASK THE COMMUNITY

TRENDING THREADS