new gigabyte gtx 1050 not working

Mar 13, 2018
5
0
10
0
my pc spec are
motherboard DH61WW
PSU great wall gw-500pw
processor is G630

after 20 sec fan stop spinning in the graphic card and monitor indicate check video card.

so I'm planning to replace PSU with new Thermaltake TR2 Challenger 600W. but not sure the power is case here. does bios version effects to this or any other problem. can anyone one give a hint
 

Lutfij

Titan
Moderator
You may want to make sure you're on the latest BIOS version. Is the system a prebuilt unit or was it built with off the shelf parts?

The existing PSU is bad, the PSU you'e looking at is the same kind of bad. Where are you located and what's your budget?
 

Sam Hain

Honorable
Apr 21, 2013
366
0
10,960
60
Along with Lutfij's suggestions, if you've not already performed this as you did not mention doing so... If you had a previous GPU, (esp. AMD) you want to ensure all traces have been deleted/removed; i.e drivers, folders, control panel programs, etc, etc. to include NV drivers even if you had a previous-gen NV GPU installed. This will require booting/logging in SAFE-MODE to do this.

Installing newer-gen NV GPUs with prexisting older-gen (GPU) NV drivers does not always "compute" so-to-speak.

Install new NV drivers/software as needed for your GTX 1050.
 
Mar 13, 2018
5
0
10
0


the system is a prebuilt one, currently running with Nvidia GT 710. Thermaltake TR2 Challenger 600W PSU like around $70 here. can you suggest good PSU Band
is Cooler Master Lite 600W is good one. kind a same price here
 
Mar 13, 2018
5
0
10
0
I bought a new cooler Master 650w psu. 80+ bronze. but still the same. now I'm trying reinstall windows in UEFL. may be legacy bios is the case. and I also not sure converter I use for DVI to vga. these are my only options. please anyone give me something
 

ASK THE COMMUNITY

TRENDING THREADS