New GIGABYTE Radeon 7970 Display Crashes + Computer Freezes AFTER Exiting a Game

Tree Fiddy

Honorable
Aug 18, 2013
26
0
10,530
0
I recently bought a GIGABYTE 7970 and something weird has come up. So far I've only played a few games, one of which is Far Cry 3 Blood Dragon.
The games run fine, infact they run amazingly, until I leave the actual game.
When I exit the game, the desktop will last maximum 2 minutes before the screen starts bugging out ridiculously until the screen will either go black, white OR completely striped. The computer freezes along with it as I can't get Windows to shut down properly by single-pressing the power button, but I have to hard reboot the computer by holding the power button.
When I sometimes reboot, the Windows login screen looks like its been hit with a hammer; A lot of the screen is covered by black rectangles and bugged out pixels until the screen sometimes goes black, white or striped. Sometimes it even BSODs
After trying again, the screen looks fine. I can start up a game and play for a matter of hours. Upon exiting again, the screen bugs out, dies and I have to reboot again.

I've been trying to RMA but Newegg and GIGABYTE have been fucking me over repeatedly and my warranty is just about to finish.
What do you guys think, and if there is a solution can someone please help me. I'm desperate at this point
(UPDATE: I'm going to try RMAing with Gigabyte after calling them, hope it goes well. But I'd still like some input from you guys on this thread)

PS: Heat is not the factor because the hottest my card has ever gone under stress is 66C

System Specifications:
8GB DDR3 GSkill Ripjaws RAM
XFX 80+ Bronze 650W PSU (Non-Modular)
GIGABYTE 7970 3GB (Factory OCed to 1000/1375 mhz)
MSI Z77A-GD55 Motherboard
Intel Core i5 3570k 3.4GHz w/ stock cooler
NZXT Phantom Full ATX Tower Case (White)
 

Tree Fiddy

Honorable
Aug 18, 2013
26
0
10,530
0


My hard drive is still fresh, almost completely empty. I've downloaded my chipset drivers from MSI already and I have tried doing clean installations of my GPU drivers. As I said, games work amazingly, but something else is killing it when it gets back to the desktop
 

Tree Fiddy

Honorable
Aug 18, 2013
26
0
10,530
0

Thanks! I will test and update the thread with the results. But for now, I am leaning towards the GPU being the culprit
 

Tree Fiddy

Honorable
Aug 18, 2013
26
0
10,530
0

Finished testing. Pass with no errors :/
 

Tree Fiddy

Honorable
Aug 18, 2013
26
0
10,530
0


It either crashes after exiting ANY game, or just staying idle on the desktop for a few hours. All of my HDD is partitioned for Windows, and has over 800GB free for storage
 

rounakr94

Honorable
Jul 28, 2013
1,365
0
11,660
150
Can it be a faulty GPU or a monitor problem are the questions that come to my mind. I suggest you RMA it and are you sure that your monitor is okay? Can you reformat windows and install like this update bios>format>drivers for monitor(if any)>chipset drivers>audio drivers>graphics driver(amd catalyst 13.8beta) and other necessary drivers like ethernet drivers etc. Then run a prime95 stress test and any gpu stress program one by one(cpu first) and see what happens and please post it here.
 

Tree Fiddy

Honorable
Aug 18, 2013
26
0
10,530
0


I've had people suggest it's a monitor problem, but I've tried my monitor and my HDTV and I've got the same problem. I have not tried using a different cable, I've been using HDMI. I'll go out and buy a DVI cable and see if there is any difference (Sounds stupid, but doesn't hurt to try.) If nothing changes, I will follow your steps of reformatting and updating drivers and BIOS and run Prime95. I will update you as soon as I get results.

Just a side note: I have tried several clean installs of 13.4 and 13.8 [BETA] Catalyst drivers with not much difference other than a weird artifact in Crysis 2 appears in 13.8.
 

Tree Fiddy

Honorable
Aug 18, 2013
26
0
10,530
0


Oh yeah btw, my Windows is OEM, how would I be able to reinstall?
 

Tree Fiddy

Honorable
Aug 18, 2013
26
0
10,530
0
I decided to try out Furmark, since I never actually did a stress test on this card. It went ok for 30 seconds an then the screen started freaking out and soon enough crashed in its usual manner. Max temp it reached was about 67C, but I stripped my case so it had maximum airflow, since this would have raised the tempurature like crazy.
So could this narrow it down to the GPU being faulty?
 

Tree Fiddy

Honorable
Aug 18, 2013
26
0
10,530
0
GIGABYTE sent me a bunch of things to try. One of which was doing a clean reinstall of the drivers, taking out the system from the case and removing one stick of RAM. Furmark ran fine throughout the test, but as soon the I exited furmark, surprise surprise, the screen artifacted and crashed as usual
And rebooting came up with flashing artifacts on screen.
 

Tree Fiddy

Honorable
Aug 18, 2013
26
0
10,530
0


They just granted my RMA, I just wanted to make sure that nothing else is causing this problem, but from what I've been experiencing very recently it all points to the GPU being the problem.
 

Gattana

Honorable
Aug 12, 2013
9
0
10,510
0
Tell me if it worked, because I´m having the same prob, as you already know, soon I will get the pc checked and I´ll bet it´s the GPU
 

Tree Fiddy

Honorable
Aug 18, 2013
26
0
10,530
0


Will do, and update me here when you get your PC checked as well
 

toyftw

Dignified


You can reinstall as long as you have the same motherboard.
 

Tree Fiddy

Honorable
Aug 18, 2013
26
0
10,530
0


Ah ok, thanks.
 

Tree Fiddy

Honorable
Aug 18, 2013
26
0
10,530
0
So Gigabyte just screwed me over. They refused to fix my GPU because the PCB was damaged. They sent pics of it, and I'm sure it wasnt damaged at all when I sent it. They're sending it back to me even worse that it was before.
 

toyftw

Dignified


Yes, you can reinstall if you have the same motherboard.
 

Similar threads


TRENDING THREADS