Question New GPU installed, Black screen on boot, no bios, no power on peripherals

Dec 26, 2021
5
0
10
0
Hi everyone.
Hope you're having a nice day so far.

I just bought a EVGA Nvidia RTX 2060, and now when I boot I face a black screen, with no power to peripherals. The fans spin, and the blackscreen goes on forever.
If I force shut down the PC, and turn it on again, it will boot bios (safe boot, I believe), and display a warning, saying I force shut down the pc and to check BIOS config. From here I can select my Windows Boot Manager and start Windows manually.
The card works right, I can play videogames without issues, but when I suspend the system or turn it off, the next time I turn it on I face the black screen again.

I tried disabling the onboard graphic adapter (was disabled by default, but I booted the system on safe mode to do it as suggested here https://forums.tomshardware.com/threads/black-screen-after-installing-a-new-graphics-card-a-bit-of-a-noob.1356753/ ---- still, didn't work.)

I tried deleting the drivers from both my old and new GPU with DDU. Installed the latest Nvidia drivers again. Didn't work either.

I updated the Motherboard BIOS, but still on the same page.

I switched the boot from "UEFI + Legacy" to "UEFI only", and disabling CSM altogether. Still the same issue everytime.

I selected the PCIE as my main Graphic interface in the BIOS. Black screen still.

I have read a lot of posts with this same issue (I guess its pretty normal after installing a new GPU, isn it?) but none of the solutions provided worked for me.

Here are my specs. You can download a more in depth HTML report exported from CPU-Z https://drive.google.com/file/d/1EprBVWN6H9YueOSD72CuWW7eWLGD4xIf/view?usp=sharing

Old GPU: Sapphire Radeon R9 290X​
New GPU : EVGA Nvidia RTX 2060​
Motherboard: Asus Z170-A​
PSU: Corsair VS550​
CPU: Intel i7-7700k​
RAM: 2x Crucial Ballistix 8gb 3200mhz​
SSD: 240GB M2 SATA Western Digital Green​
HDD: 2x Western Digital Blue 1tb (WD10EZEX)​

To reiterate: the weird thing is that at first doesnt boot to BIOS, is only after I shut it down and turn it on again that it reaches BIOS, with the warning about forcing the shut down. From there I can use the PC no problem, but it is annoying nonetheless.

Thanks in advance for the help, I appreciate the time reading me. Have a great holidays!
 
Last edited:
Dec 26, 2021
5
0
10
0
Have you updated your motherboard chipset drivers during any of this?

https://www.intel.com/content/www/us/en/support/intel-driver-support-assistant.html

You can get the latest Intel drivers at the link above.
Nope, I didn't know about it until you mentioned it. Here you have a screenshot https://drive.google.com/file/d/19n5o-9SSm0klayUVNBkHyyDPFbJ55NYM/view?usp=sharing

I believe, thought, that I have the latest GPU drivers, since I redownloaded them yesterday. The Motherboard BIOS too (the latest version was from 2018 anyway).
 
Dec 26, 2021
5
0
10
0
Use the tool there to identify all available Intel devices and update the drivers for them.
I just updated all the Intel drivers (Chipset and IGFX were outdated), also checked the drivers for other components from Intel that were not listed through the Device Manager. Still getting the Black Screen :(
 
Dec 26, 2021
5
0
10
0
Ok, I found the issue.


If you remove the 2060 and boot with the integrated GPU, does this problem go away?
I tried that, and it didn't work either. Same black screen.
I tried wiping the CMOS memory, and it worked! I tried with the PCIe 2060, and worked fine as well.

But that begs the question: why?

So, I noticed that my RAM now has a lesser frequency (2400 hz), and tried overclocking it and now I have the black screen again.

Conclusion: I might be a little tight on juice from the PSU, or I should check if I have any issue with my motherboard and the RAM's clock.

Anyway, we can close this thread. Thanks a lot for the assistance COLGeek!


edit: So, I just found out that my CPU only supports RAM up to 2400hz, so thats it. Gotta update my rig I guess.
 
Last edited:

COLGeek

Cybernaut
Moderator
I used an XMP profile. I never tried overclocking it myself, Im afraid I could mess something up.
Understood.

You can try a lower speed (like 3000) and see how the system performs. Not all memory will work at rated speeds in all systems.

If you are stable now, I wouldn't worry about it. Unless benchmarking, you'll see little real world difference when performing normal tasks.
 

ASK THE COMMUNITY

TRENDING THREADS