Question New GTX 1660 super 0% GPU usage in games

Steve_K7

Reputable
Oct 26, 2016
55
0
4,540
2
Hi everyone, so I today I upgraded my GPU from a Rx 480 to a gtx 1660 super. I've uninstalled all amd Radeon softwares and installed Nvidia control panel as well as GeForce experience and updated all my driver's for my GPU, windows and mobo. But when I'm in game my GPU usage is always at either 0% or close to 0. I don't know what's going on. Am I getting bottlenecked by my cpu? I'm running a i7-6700 (non k). I've did a lot of research before hand and many have told me that id be ok. I need help figuring out what is wrong.

Ps: when I'm playing warzone it is the worst. I'm getting 0% GPU usage and 85% cpu usage and an avg of 80-90 fps on low settings.
 

Steve_K7

Reputable
Oct 26, 2016
55
0
4,540
2
What's the system? Including monitors and hook ups?
i7-6700
Asus z170A mobo
Gtx 1660 super
Corsair vengeance 16gb
1 Tb Samsung 850evo
4tb barracuda
650w psu
2 Samsung 1080p 60hz monitors
Hooked up via HDMI (one has a HDMI to DP adaptor since it only supports HDMI)
 

Steve_K7

Reputable
Oct 26, 2016
55
0
4,540
2
What program do you use to see the utilisation? If you see it through task manager it's 100% incorrect.
I would suggest MSI afterburner with the OSD or HWinfo.

Exact make and model of your PSU?
so I figured it out. I downloaded after burner and looked at it. Gpu usage is at 70-99%. And cpu is at 78-50%. I turned cpu & gpu timing on in game and it seems the cpu is bottlenecking the gpu by 20-30 FPS.
 

Steve_K7

Reputable
Oct 26, 2016
55
0
4,540
2
Just so we know, what were you using to look at GPU usage?
Before I was using task manager. Which was incorrect, then I used afterburner and found out I have a small bottle neck from my cpu. So I've decided to upgrade my cpu to a Ryzen 2600 and a b450 or x370 mobo
 

ASK THE COMMUNITY

TRENDING THREADS