Question New HD/Windows Install After BSOD, Touchpad Unusable

Aug 5, 2020
1
0
10
0
Hi all,

My mom's laptop (Asus x540s) had a bsod that I worked out to be a dead/corrupted hard drive. I installed a new SSD to replace the HDD and reinstalled Win10, but from the get go in setup, I had no access to the touchpad.

The touchpad doesn't appear in Device Manager, the only thing there is an I2C HID Device that has a warning on saying "The device cannot start. Code 10. A request for the HID descriptor failed".

I've done a lot of research and asked around but no solution has been found yet. So far I have: reinstalled Windows multiple times; replaced the touchpad and cable with new ones; installed every driver, software, chipset, and BIOS on the ASUS support page and in different orders as well as older versions of the major ones; installed generic touchpad drivers for all major manufacturers (later figured out it's made by ELAN), then tried multiple ELAN drivers; downloaded a USB run Linux distro to try to get access to the touchpad sans-Windows; enabled and disabled the touchpad setting in the BIOS; uninstalling the I2C HID Driver; used the keyboard control to turn the touchpad on/off; and other random suggestions from around the web.

Any help you can provide would be greatly appreciated, thanks!
 

ASK THE COMMUNITY

TRENDING THREADS