Question New Headphones. Some games play audio. Others are dead quiet.

Sep 22, 2021
Prefix: I'm dealing with the same issue as this thread right here from 7 years ago. I have not been able to solve it yet.

Here's my version of the same story:
I used a Logitech G430 for many years as my primary headset. It broke for the 2nd time at the same spot (the C clips that connect the muff to the band are weak plastic and stress-crack until they fail) so I upgraded to some Beyerdynamic dt-770 pro 250 ohm studio headphones and a Sudotack ST800 mic. Headphones are 3.5, mic is USB, and the old G430s were a pair of 3.5 mic and headphone jacks going into a usb adapter.

Audio is fine, except for VR Chat, Generation Zero, and (until I fixed it) Dishonored 1.

-VR Chat: No audio at all. The microphone doesn't even come up as a selectable device in the settings
-Generation Zero: No audio at all.
-Dishonored 1: No audio until I opened "Open Sound Settings > App Volume and Device Preferences" and manually set Dishonored 1 to use the new headphones instead of Default. It worked, but then it gets weird: I switched it back to Default and instead of it going mute like before, it just works now.

Here's where things get even funkier: As mentioned, the the G430 has a mic/speaker jack to usb dongle. This is what I've used since day 1. If I plug the dongle by itself into the PC the PC thinks the G430s are plugged in and everything defaults to it. Games, web browsers, VLC, Windows sounds, etc, even the microphone. I decided to plug my new headphones into the dongle. Lo and behold, VR Chat and Generation Zero now have audio. To add to the strangeness VR Chat will default to the dongle too, but it will now detect the ST-800 and have it as a selectable option. Unplug the dongle, the option goes away.

Solutions tried:
-Updated Realtek drivers
-Triple checked my headphones were set up as the default device
-Manually tried overriding the defaults in App Volume and Device Preferences
-Worked for Dishonored, didn't work for anything else.
-Disabled all audio devices except for the DT-770s and ST-800
-Tried making one of my monitors the default device, then switching back to the headphones
-As a side note, the monitor I selected played VR Chat and Gen Zero audio instantly when switched. Switched back to the headphones, and heard nothing
-Tried making one of my monitors the default communication device
-Tried to lower the quality of the headphones
-Uninstalled Logitech Gaming Software and deleted the saved preferences in AppData
-Disabled Peace/Equalizer APO (not sure if it actually turned off though) that I use alongside my headphones

I'm stumped. So far any other thread I've read on here, Reddit, or Steam is a dead end or a "I gave up and reinstalled Windows."

PC Specs:
Windows 10 Home, 21H1
MSI X370 Gaming Pro Carbon
AMD Ryzen 5 1600
NVidia Geforce GTX 1070
32 GB RAM, G.Skill Ripjaws V
2 SSDs 2 HDDs and 1 M.2
Try using just the new phones and mic, but before you do, check Device Manager to make sure any software associated with the old headset is disabled, or better yet, uninstalled. This sounds like it could just be a W10 peripheral detection conflict to me. I'm not sure if the 21H1 build is perhaps more inclined toward that, as I'm still running 20H2. I tend to not upgrade to the next build until I'm pretty sure it won't cause problems.

The Beyers are a great choice btw. I've had the DT-770 Pro 80 Ohms for some time now, and absolutely love them. I recommend storing them by placing something just long enough between either side of the headband to keep the earcup cushions from pressing against each other. This ensures the cushions will have a better chance to rebound to their full size, which matters a lot if you wear them at length, and especially if you wear prescription or blue blocker glasses with them. A mini LED flashlight I have works perfect for this, though it's a bit larger and more heavy duty than the cheapo tiny ones.
Last edited: