New high end amd system getting LOW FPS

Discipleoflife

Honorable
Feb 23, 2013
43
0
10,530
0
Ok so i have an fx-6300 with a hd 7950 3gb. and a 970 board. with 8gb of 1600 g.skill ram and a 575W diabloteck psu. and im getting less Fps than i was getting with my phenom 1 X4 2.4 and a 550ti. Please help me.

Obv i can play games at much higher details. But even in lower setting my framerate has gone to shit.

Games i play:
Crysis 3 (must play on low-med)
battlefield 3 (seems to work on high)
SWTOR (surprised i cant max)
League of legends (LESS THAN 50 FPS IN LOWEST SETTINGS! W!T!F!)
Hawken (less than 60 fps ALWAYS)
World of tanks (cant go anywhere near high settings and low settings dont help much)
Vindictus (30 fps avg, this is not that great looking of a game)
Planetside 2 (30fps, tho i hear this is normal for the game as very cpu intensive)
BIOSHOCK INFINITE (very low settings 30 fps)

ALL games have v-sync disabled and no fps cap programs in place (not new to this)

I have fresh install of win 8, with 13.3 or whatever latest beta drivers.
GPU is OC to 1000mhz and 1500 mem. CPU is stock.
Temps are normal and hardly a factor.
cpu RARELY bottlenecks (if ever, usually below 70%)
dunno how to test the load on my gpu, but im having a hard time believing a 7950 could be bottlenecking me this much.

PLEASE HELP ME WTF IS WRONG!

Also for league of legends I KNOW i was playing at CAPPED 60 fps. Now below 50. For such a simple game i cannot understand how im not getting WAY higher fps.
 
Do you have MLAA and/or v-sync forced on in the CCC? V-sync sounds likely.

You should try running 3dmark11, and post the results in performance mode. That should let us know if you have a setting on or you have hardware/software issues.
 

Discipleoflife

Honorable
Feb 23, 2013
43
0
10,530
0


ok, checked amd vision engine control center.. and vsync say to "application settings" and AA is at "multisampling" but there is no "off" or "disabled" i think this is just what kind of sampling it uses.. not whether it uses it or not.. and everything else is at "use application settings"

Im dl 3dmark right now.. but i've run Unigine and got a score of 2000
Is this normal?
 


Your 3dmark11 score should be around P8000-P9000, and about 9k-10k on the graphical score. What is it you are getting? Don't run it in extreme, use the performance preset.
 

Discipleoflife

Honorable
Feb 23, 2013
43
0
10,530
0
Ok.. So...

Just ran 3dmark 11 and i got:
SCORE
P6730 with AMD Radeon HD 7950(1x) and AMD FX-6300
Graphics Score 7865
Physics Score 4707
Combined Score 4686

However its 3dmark11 BASIC in 720P
it wont let me do extreme (1080) without paying.


And unigine scores between 2000-2100

I did notice during the 3dmark test i was failing miserably at the Physics. with sub 15 fps. however it says i scored well... is this normal then?

Also, I have resinstalled drivers MULTIPLE times. As well as plugged in my laptop v of win 8 to test if its soft issues. Unless im missing something cause my gpu drivers are the latest.

Vsynch is off on every game. if theres an game side fps cap its set to max or benchmark.
 


Well, the graphics score is about what I've been finding when doing a google search, so the card is performing normal. However, the low overall score is a result of your CPU giving poor physics scores. It could also be a bottleneck in games. You might want to check the temps to make sure its not overheating (the CPU).
 
You may be running normal. Though I suspect in game settings on some of those games has v-sync on. I know many online games tend to not go to very high FPS as well. Even if they seem like they are easy. Online games tend to have CPU and internet requirements that keep you slower than offline games.

3dmark11 found your 7950 to be in normal range. Your CPU is obviously your weak link.
 


One way to check is to use MSI Afterburner and check the GPU load when gaming. If it is being held back by the CPU, the load will be low. OCing the CPU and using the turbo, would also help know if it helps, as your FPS will increase.
 

Discipleoflife

Honorable
Feb 23, 2013
43
0
10,530
0
Sigh.. i turned on turbo core and disabled my power settings. because the fisrt run it showed my cpu as being at 1.4ghz... which is the lowest my powersetting will drop it.. but i set it to run at constant 3.5. the test showed turbo core as it reported it at 3.8 but yet i still got low physx scores! :(
SCORE
P6790 with AMD Radeon HD 7950(1x) and AMD FX-6300
Graphics Score 7949
Physics Score 4710
Combined Score 4745

I dont know whats up. I know AMD is behind intel in games. but not THIS behind right? is there something wrong with my cpu?
 

Discipleoflife

Honorable
Feb 23, 2013
43
0
10,530
0
Unless im an idiot. There isnt drivers for the CPU right? I have chipset drivers. but i dunno. I've had this cpu for barely a month. -.- but i think i cant rma it anymore :(
 

Discipleoflife

Honorable
Feb 23, 2013
43
0
10,530
0


It says that cpu has 8 cores on a 6300.. and 4.9 wow... didnt know u could oc it that high. also his 7950 is getting a 10000 score when mine is getting 7000. Whats with that? just that little bit extra oc? So then... do i need to overclock my comp to play leage of legends at 60fps? cause i did that back on my phenom 1 2.4 / 550ti as well as when the fx had the ti. So i dont see how a processor upgrade could result in less performance...

it seemed like when i first installed my gpu card it was running faster than this. -.- either im just a bad stoner with bad memory. or its actually performing worse. is maxed league with 60 fps really unattainable?

Would temporary overheating cause the cpu to degrade? myb somehow it overheated at one point and i didnt notice?

I was looking at overclocking as a "later on" thing as im jobless. i guess stock 6300 just cant cut it? I guess im going to need to look into an evo 212. just would had to overclock the cpu and find out there still is something wrong.
 

Discipleoflife

Honorable
Feb 23, 2013
43
0
10,530
0


is there another test that can confirm its the cpu? So what would ur suggestion be for my cpu? is it simply lost? should i get another? or would another 6300 be just as bad? Do i NEED to oc it? cause right now most games are unplayable. and this whole mess is making me wanna cry :(
 
If you want high end FPS consistently, you'll want a high end Intel CPU. The high end AMD CPU's will be hit and miss in games, depending on whether they need fast cores or like more cores. You have an AMD CPU that would be fine if you were ok with 40ish FPS in some games.

Crysis 3 is a CPU killer, you pretty much need to go high end or go home. You also cannot expect to "max" most games. PC games have sliders, and high end options not meant to be used by most people.

Btw, are those numbers are average, max, or minimums?
 

Discipleoflife

Honorable
Feb 23, 2013
43
0
10,530
0
The fps are avg. I understand i cant max crysis 3. but on high i run at like 27 fps, and on low i run at 34 ish. Battlefield 3 runs at 40+ish avg high which i guess is awesome. but most games running 30-40ish avg which means dips sometimes down into the 10s and that is NOT what i expect. most games grpahic settings dont change much. However its my LOW end games taht are showing the problem. Such as league on high and BS:I on VERY LOW. (i have moar like it) that are ALSO in the 30-50ish range. Which with the notorios microstutter and fps drops makes it quite hard to play. I turn the graphics down on leauge to low and i get 100s fps but i could play league on very high with NEVER below 60 with my 550ti with same processor. I use league as my expample because its the lowest graphics game i can think of.
 
It does sound like something is an issue. Perhaps you need to update your drivers and BIOS. Checkout GPU-Z, make sure the bus interface is correct, see if you have enough PSU power, which can cause throttling. See if the CPU is overheating, that sort of thing.
 

Discipleoflife

Honorable
Feb 23, 2013
43
0
10,530
0
Well, i definitely know something is up, because all the sudden it has stopped.
I didnt really do anything to fix it. But im getting 100S fps in league and MUCH better Fps in my higher end games.
While im super glad its working right now, I do still wonder what might have caused the problem so i can avoid it next time.
lol.
THANK YOU BYSTANDER! Your responses were quick and helpful.
I'll post again if the problem resurfaces. (please dear god no)
I've give you a cookie, but internet cookies taste like cardboard.
So i will just say, If i have another problem someday, I hope your still on the forum!

THANK YOU

 

Similar threads


ASK THE COMMUNITY