Question New Laptop Gigabyte AERO 16 XE4 Issues with USB & Bluetooth when gaming

Aug 15, 2022
1
0
10
0
I bought a Gigabyte AERO 16 XE4 few months ago and recently started to try some gaming on it. The bluetooth and USB ports fail randomly when gaming. The system works 100% fine when not gaming and never had any issues so I think it may have something to do with the graphics card or system overheating (?). When I start gaming, the USB ports and Bluetooth will fail and disconnect. Unplug and plugging back in gets a USB device not supported error most of the time. Only the trackpad works on the laptop after the ports fail. The onboard keyboard doesn't work and have to do a hard reset to get things working again. If the ports don't fail, the other error that happens is system just shuts down with blue screen (clock_watchdog_timeout) or no blue screen.

I've tried the following:
  1. Install all drivers from the Gigabyte manufacturer support page. Didn't work.
  2. Install various drivers from the other hardware manufacturers (nvidia, realtek, intel, etc). Old & new. Didn't work.
  3. Turned off legacy USB support in BIOS.
  4. Updated BIOS to most recent version.
  5. Turned off all USB suspend in main power settings and unchecked 'turn off to save power' option in power management tab for devices.
  6. I've installed clean copy of windows 10 on a partition. Didn't add any software besides the game. Only keyboard, mouse, and display plugged in directly via usb-c. Just let windows install all the drivers. This is the most stable and error doesn't happen as often but still occurs. I'll mention that one USB controller device in the device manager is shown with an error and windows can't find the correct driver to install. This may be the problem device. I have tried disabling it and error still occurs.
I've monitored my temps and nothing gets too hot (max around 75-80 C) per my understanding. I'm using a laptop cooler. Trying not to RMA it since I need to work on the laptop as well.

Any suggestions would be appreciated. :kissingheart:
 
Last edited:
I bought a Gigabyte AERO 16 XE4 few months ago and recently started to try some gaming on it. The bluetooth and USB ports fail randomly when gaming. The system works 100% fine when not gaming and never had any issues so I think it may have something to do with the graphics card or system overheating (?). When I start gaming, the USB ports and Bluetooth will fail and disconnect. Unplug and plugging back in gets a USB device not supported error most of the time. Only the trackpad works on the laptop after the ports fail. The onboard keyboard doesn't work and have to do a hard reset to get things working again. If the ports don't fail, the other error that happens is system just shuts down with blue screen (clock_watchdog_timeout) or no blue screen.

I've tried the following:
  1. Install all drivers from the Gigabyte manufacturer support page. Didn't work.
  2. Install various drivers from the other hardware manufacturers (nvidia, realtek, intel, etc). Old & new. Didn't work.
  3. Turned off legacy USB support in BIOS.
  4. Updated BIOS to most recent version.
  5. Turned off all USB suspend in main power settings and unchecked 'turn off to save power' option in power management tab for devices.
  6. I've installed clean copy of windows 10 on a partition. Didn't add any software besides the game. Only keyboard, mouse, and display plugged in directly via usb-c. Just let windows install all the drivers. This is the most stable and error doesn't happen as often but still occurs. I'll mention that one USB controller device in the device manager is shown with an error and windows can't find the correct driver to install. This may be the problem device. I have tried disabling it and error still occurs.
I've monitored my temps and nothing gets too hot (max around 75-80 C) per my understanding. I'm using a laptop cooler. Trying not to RMA it since I need to work on the laptop as well.

Any suggestions would be appreciated. :kissingheart:
This saddly sounds like a hardware failure you've basically covered your trouble shooting basics only other step really left would be try new ram
 
Nov 24, 2022
1
0
10
0
Hi. I had the following problem:

My Gigabyte Aero 16 XE4 came with a factory Gigabyte Control Center and I updated all drivers from that factory app. It gave me problems with my keyboard (it was locked) and I got the error Device Driver Descriptor (error 43 USB Port). I tested almost every solutions gave in YouTube and most of these possible solutions that you tried. None fixed the problem.

Also I downloaded all drivers from website, one by one and manually installed them. Didn't fixed the problem (including updating BIOS)

So I realized it was a driver problem, what I did was.

  1. Reset Windows.
  2. I made a clean installation (at this point, this new installation doesn't brought Gygabite Control Center as it came by factory).
  3. Updated Windows (11 2022). At this point, Windows downloaded the needed and correct drivers by itself.
  4. Downloaded the Gygabite Control Center from the official website.
  5. Ran Gygabite Control Center and check for updates. It only needed to update 3 stuff because Windows downloaded correct drivers).
  6. Run Windows Update after Gygabite Control Center updated. At this point, Windows was up to date.
  7. Checked Gygabite Control Center for new updates, it was up to date.
Problem fixed with drivers. I think I had problems with

A) Using the factory Gygabite Control Center and downloading drivers from it without making a Windows Update.
B) Installing drivers manually.

Just let Windows update do the job.

Hope this can help you because I was so anxious looking for solutions that didn't fixed the problem.



Then, I downloaded the Gigabyte Con

I think there's a problem between Gigabyte Control Center and the factory drivers that comes with the app.
 

ASK THE COMMUNITY

TRENDING THREADS