Question New M.2 SSD shows up in Windows but not in the BIOS ?

Feb 6, 2021
1
0
10
0
I recently bought a m2 SSD and tried installing it in my Dell Inspiron 5580. I installed and screwed it tight but when I try to install windows in it, the setup does not recognize it. I also cant find the disk in the BIOS but when I started Windows in my old HDD and checked the disk management, the SSD was there. I initialized and created a new partition, tried rebooting and checking if it showed up in the BIOS with no success.

Next step I tried installing windows in it directly via the old HDD, clicked on the setup executable and then it was found, the setup ran and it said it finished copying files.
But when the PC restarted it said that windows could not find the partition to conclude the setup.
I still cant find the SSD in the BIOS.
I tried setting to Legacy mode but the bios says something like "Legacy Boot mode is not supported on this platform".

Tyvm for you help
 

Lutfij

Titan
Moderator
Welcome to the forums, newcomer!

Make and model of the M.2 SSD that you've purchased? Since you can still boot to the OS's GUI, use CPU-Z to see what BIOS version you're currently on. Then you need to use your laptop's Service Tag on Dell's support site, here, to see if you have any BIOS updates pending for your laptop. If you have a number of BIOS updates pending, gradually work your way until you reach the latest version, taking note of any MEI or chipset drivers that might need installing in between BIOS updates.

You should ideally be in UEFI mode and your storage controller set to AHCI.
 

ASK THE COMMUNITY

TRENDING THREADS