New Mini-ITX Build not Booting/Posting

romanceexplosion

Honorable
Sep 5, 2013
2
0
10,510
0
Hi guys,

As the title says, I'm having issues with my new build.

Parts are:

Bitfenix Prodigy Case
Gigabyte Z87N WIFI Motherboard
Intel Core i5 4670k Haswell CPU
2x4GB GSKILL Sniper Series DDR3 1866 RAM
Sapphire Radeon HD 7850 2GB GPU
1TB WD10EURX IntelliPower 6.0Gb/s HDD
Corsair Force Series 3 120GB SSD
Antec BP550 Plus 550W Modular PSU
Pioneer BDR-208DBK Blu-ray Burner/Reader

I've gone through a lot of threads here, gone through the step by step process that everyone links, and am still absolutely stuck. I've never had this much trouble with a build (this is my fourth).

Right now I have the board out on some cardboard as I've been trying various part combinations and always get the same result; everything appears to power on for a second (CPU fan, Case fans, HDD whirs, Disc Drive spins, etc) and then stop, nothing ever appears on the monitor, the computer continuously reboots and loops this process until i disconnect power. I have tried another PSU (Corsair 550W) and HDD that are known to be working and the same thing happens. I have no additional DDR3 RAM to test at this moment but will try and find some at my office tomorrow.

I have also checked the motherboard version (1.0) with the manufacturer's website to verify that it is combatible with my processor; it says that it is.

I do not believe there is a place to attach a case speaker on this board,if there is and someone could point me in the right direction that would be great. Due to this, I'm not able to hear any beeping that may be occurring; there is no visible light on the motherboard either to tell me something with flashes etc.

Again, any suggestions would be wonderful as I am getting extremely stressed with something I had expected to be fun. I can only handle so much troubleshooting. Do you think the board could be faulty?
 

ASK THE COMMUNITY

TRENDING THREADS