Question New mobo and cpu, no signal

Jan 19, 2021
4
2
15
0
Hi everyone,

I am replacing my motherboard, cpu and ram for the first time and I seem to have a few problems. I have connected everything in the right place as far as I know, but when I power the pc I get:
  • a no signal on my monitor when i connect the display port to the gpu, hdmi to gpu or hdmi to mobo.
  • gpu fans keep spinning at what I assume is 100%
  • holding down the power button does not shut down the pc. It is not broken because it is able to turn on the pc.
Mobo: x570 aorus elite
Cpu: amd Ryzen 5 5600x
Gpu: nvidia rtx 2080 super
Ram: corsair vengeance lpx ddr4 16gb (2x 8gb) 3200mhz

Am I doing something wrong or do I have a faulty component? Thank you :)
 
Last edited:

Wolfshadw

Titan
Moderator
Gigabyte X570 AORUS Elite - CPU Support List
This motherboard requires BIOS version F30 in order for it to support the Ryzen 5 5600X processor. More than likely, you will need to update the BIOS.

Gigabyte X570 AORUS Elite WiFi - Motherboard Manual
Oddly enough, the link on the Motherboard's Support Page to the manual leads to the WiFi version of the board. Not sure if there is a difference, but look to Pg. 23 and the Q-Flash Plus instructions for updating your BIOS.

-Wolf sends
 
Reactions: Darrai
Jan 19, 2021
4
2
15
0
Gigabyte X570 AORUS Elite - CPU Support List
This motherboard requires BIOS version F30 in order for it to support the Ryzen 5 5600X processor. More than likely, you will need to update the BIOS.

Gigabyte X570 AORUS Elite WiFi - Motherboard Manual
Oddly enough, the link on the Motherboard's Support Page to the manual leads to the WiFi version of the board. Not sure if there is a difference, but look to Pg. 23 and the Q-Flash Plus instructions for updating your BIOS.

-Wolf sends
Yes, the manual is the same for the elite and elite wifi. I have the manual here. I'll try what you adviced!

Thanks :D I'll let you know if that fixed it.
 
Reactions: Wolfshadw

ASK THE COMMUNITY

TRENDING THREADS