New mother, no video. Bios update needed

juampidieguez123

Prominent
Aug 29, 2017
23
0
520
2
Hi guy, today i bought and installed a new mobo, processor and ram. I got the asrock ab350m-hdv, a ryzen 3 1300x and a 2 kit of hyper x fury of 4gb (8 total). The thing is that when i turn my pc on i get no display, no video output(I do have my gtx 1060 pluged in and working). I looked up for people with the same problem and they said that it was due to a necessity of a bios update. So I would like you to tell me if that info is correct and if it is how should i proceed. Should i update the bios myself(trough a usb drive or smth like that) o should i take it to a local tech support?
Thanks for reading and concerning.
 

juampidieguez123

Prominent
Aug 29, 2017
23
0
520
2
MERGED QUESTION
Question from juampidieguez123 : "Problems on booting up new build"

Hi guy, today i bought and installed a new mobo, processor and ram. I got the asrock ab350m-hdv, a ryzen 3 1300x and a 2 kit of hyper x fury of 4gb (8 total). The thing is that when i turn my pc on i get no display, no video output(I do have my gtx 1060 pluged in and working). I looked up for people with the same problem and they said that it was due to a necessity of a bios update. So I would like you to tell me if that info is correct and if it is how should i proceed. Should i update the bios myself(trough a usb drive or smth like that) o should i take it to a local tech support?
Thanks for reading and concerning.
 

ASK THE COMMUNITY

TRENDING THREADS