Question New motherboard and CPU, but mouse and keyboard won't work

tbean1

Honorable
Nov 4, 2013
62
0
10,630
0
Hello,
I just installed an ASUS Prime X470-Pro AM4 AMD X470 SATA 6Gb/s USB 3.1 HDMI ATX AMD Motherboard with an AMD RYZEN 7 2700X 8-Core 3.7 GHz (4.3 GHz Max Boost) Socket AM4 105W YD270XBGAFBOX Desktop Processor and
G.SKILL TridentZ RGB Series 16GB (2 x 8GB) 288-Pin DDR4 SDRAM DDR4 3200 (PC4 25600) and after connecting everything and turning it on I can get into BIOS easily. The mouse and keyboard work just fine in BIOS in either usb 2.0 or usb 3.0, but once I try to boot to windows I can't move my mouse or use the keyboard at all they end up shutting off after BIOS. I have tried turning legacy on and off as well as xHCIP or whatever to know avail. Does anyone know what I can do to solve this issue? BIOS reads that all my USB ports are enabled. I don't know if I am missing something else in BIOS or perhaps it's a boot order issue? I was going to try to use ps/2 connection for my keyboard if I can find an adapter to see if I can get into Windows because I believe it might be just a driver issue. Any help would be great, thanks in advance!
 

tbean1

Honorable
Nov 4, 2013
62
0
10,630
0
I do have Windows 7, are you telling me they aren’t compatible for Windows 7 then? I did try to use my install for 7 and the mouse and keyboard still did not work
 

tbean1

Honorable
Nov 4, 2013
62
0
10,630
0
The problem was I wasn't able to install the chipset unless I was logged into Windows. But I realized that I could use my Windows 7 key for Windows 10 and that worked for me and everything is running smoothly so far! Thanks for the help!
 

ASK THE COMMUNITY

TRENDING THREADS