Question new motherboard, CPU, RAM but getting no signal on monitor.


Dec 31, 2007
Hi there,

I just replaced the Mobo, CPU and RAM in my pc and now I'm getting no signal when starting the machine.
My hardware is booting up, but the monitor is not receiving any system.
I installed the following new hardware:
  • Asus Prime B460M-A R2.0
  • I5 10400F (no integrated video)
  • Kingston Beast 2x8G 2666mhz
  • GTX 1070 (my old GPU, new GPUs are currently mad expensive)
I tried the following to try and get it to POST:
  • Checked the PSU, a 650W Corsair which is sufficient
  • Bare minimum GPU, CPU; all other components disconnected (HDD, USB, ...)
  • Reset CMOS by shorting pins and by removing the battery
  • Took out RAM modules and tried all possible slots and combinations with both 1 and 2 sticks
  • Completely took out and reinstalled every component (including CPU and cooler). Took extra attention to make sure all the necessary connectors were plugged in (8pin CPU, 24pin mobo, USB, front panel LEDs, rear panel connectors and audio, PCIE to GPU, ...)
  • Tried all possible outputs (HDMI, Display port)
Nothing worked. so I decided to reinstall my old components, everything is working fine. I'm starting to think it's a faulty
I can rule out it was the GPU or monitor, or hard drives. Anyone have any other clues?
Sep 12, 2021
I'll write some solutions which have worked from my previous experiences. first of all It would be helpful if your motherboard had a DEBUG LED system because that can help a lot In Identifying the problem. If it doesn't or does but no errors are shown, I suggest you:
  • Install the new components into your old pc ONE by ONE, starting with the RAM then CPU if it is compatible, If they both show success It means either your MOBO Is defective or has a power issue or some other unidentified issue which is a good starting point to solving your problem.
  • This may be work for you but some motherboards or at least of my experience tend to do that if they're not updated to be compatible with the used CPU, update your bios if possible. it could be outdated.