Question New NVMe M.2 is only detected when unscrewed! WTH??

Apr 16, 2020
15
0
10
0
Laptop: HP 15M-EE0023DX

Just upgraded HD to an HP EX950 nvme M.2. Many hours of troubleshooting later, I've discovered the laptop only detects the HD if left UNSCREWED. This makes zero sense to me, but confirmed it several times, screwing it in where its no longer detected, then unscrewing it again and its detected. I've adjusted the seating so many times, angled, etc. Literally the only way the ssd can get detected if its unscrewed.

The original drive is NVMe M.2 but has 2 notches (I think this is an M/B key), and when installed it lies flat without that 20 degree spring the other drive has. This original works normally when screwed, I suspect it has something to do with the issue.

Thoughts?
 
Apr 16, 2020
15
0
10
0
Before it’s screwed there is a little angle roughly 20 degrees. This is normal for m.2. That’s the only time it seems to work is by maintaining that angle.
 
Apr 16, 2020
15
0
10
0
Yep, parallel when screwed down, but then won't be detected. Contacts all look good, nothing within the adaptor housing as far as I can tell. I've googled for answers and it really seems a mystery, theres no similar issues. Makes me think maybe I have a noncompatible drive (but why then would it work normally without the screw?? If noncompatible, it shouldn't work regardless of screwed in parallel or not.)
 
Yep, parallel when screwed down, but then won't be detected. Contacts all look good, nothing within the adaptor housing as far as I can tell. I've googled for answers and it really seems a mystery, theres no similar issues. Makes me think maybe I have a noncompatible drive (but why then would it work normally without the screw?? If noncompatible, it shouldn't work regardless of screwed in parallel or not.)
I’ve not come across this and am out of ideas. Hopefully someone else has an idea.
 

ASK THE COMMUNITY