Question New PC beeps, no red light, no input to the display?

Nov 24, 2020
2
0
10
0
I had a new pc built. When it came it booted up normally no problems. After using it for about 3 hours the system shut down and when i turn the computer on, it starts beeping and doesnt send signal to the display. First, the red indicators for CPU and DRAM lit up but after reseating the RAM and clearing the CMOS they turned off. Now when I power the computer on, the controls light up and switch between CPU, DRAM, BOOT and VGA in different patterns and then they turn off and the computer just beeps.

I checked connectors, cleared the cmos and reseated ram and the graphics card. I also checked the beep codes but I found that this MOBO doesnt have a built in speaker so it must be coming out of something else? (im really not sure about whether there is or isnt a speaker in there, i couldnt find a clear answer) The beeping seems to come out somewhere under the Graphics card. I have these components:

MoBo : AsRock 550 Phantom Gaming 4/ac - AMD B550
Graphics card : Gygabyte Geforce RTX 2060 OC, 6 GB GDDR6
processor : AMD ryzen 5 3600
Ram : HyperX fury black 16GB (2x 8GB)
Power supply : EVGA superNOVA 650 G1+

Im not really skilled with PC's and this seemed weird because the system ran properly and suddenly this happened.
Thank you for your help!
 
Last edited:
Nov 24, 2020
2
0
10
0
Turns out it was a hardware problem. The GPU was broken but luckily I still had it in warranty so they replaced it with a new one. PC now runs fine.
 

ASK THE COMMUNITY

TRENDING THREADS