New PC Build - All fans spinning with no flashing lights and no shutting down

Aug 8, 2018
2
0
10
0
Hello,

I recently built a new PC with the follow specs:

- https://pcpartpicker.com/list/nNVcHh
- Titan XP GPU
- (Also ordered https://www.amazon.com/gp/product/B017HA3SQ8/ref=ox_sc_act_title_1?smid=ATVPDKIKX0DER&psc=1 to replace the power supply listed in the previous link, but have been using the original power supply for now)

I have tried stripping my build down to the bare basics with a single RAM stick, no GPU, and no wifi card. However, no matter what I add back or leave out of my build (between the extra RAM, GPU, wifi card), all my PC does is turn on all the fans and lights, while nothing shows up on my monitor (no input). I also tried reseting CMOS, by removing and inserting again the battery on the motherboard. I also tried placing my single RAM stick in different slots, but because nothing happened, I placed it back in the recommended slot.

The USB ports also seem to be working, since when I stick in my USB stick, the USB lights up. I currently have the HDMI cable connected to the motherboard directly instead of the GPU, since I have taken my GPU out for now.

Thank you!
 

You see, we need more information than "I've been through the list several times." if we are to make an intelligent guess here. That is why I asked for the results from each individual step. We can't make a diagnosis in a vacuum.
 
I am going to refer you to our general troubleshooting thread:
http://www.tomshardware.com/forum/261145-31-perform-steps-posting-post-boot-video-problems

Work through the list. WORK!, not just read!
If you still have issues, come back here with the results of EACH step in the list, and we will try to help.
Since we can neither see nor touch your PC, the results of each step gives us valuable data to allow us to eliminate possible problems and common errors to give you a reasoned diagnosis. Help to help you!
 
Aug 8, 2018
2
0
10
0


Hi!

I should have been more clear and will update my post, but I have already gone through that list multiple times: I have connected everything properly, the standoffs for my mobo were already installed, I checked all manuals and I think all parts are compatible, and seeing that my computer stays on if I don't turn it back off it seems that there are also no shorts.

Thank you for the link however! Any and all suggestions are welcome.
 

You see, we need more information than "I've been through the list several times." if we are to make an intelligent guess here. That is why I asked for the results from each individual step. We can't make a diagnosis in a vacuum.
 

ASK THE COMMUNITY

TRENDING THREADS