Question New PC Build Boot/BIOS issues

Oct 18, 2020
9
0
10
0
I have recently finished acquiring and installing the parts for a whole new PC. When I powered the build on for the first time, I noticed that the PC would not output to the monitor. I tested the monitor, cable, and tried out a different connection type. The monitor was able to display for a previous gen console. It appears that the issue lies with the PC. I spoke with some online acquaintances who recommended I remove my GPU, since the issue could have been one of power or VGA selection conflict. This did not resolve the issue.
Hardware List:
*ASRock B550M Pro 4 Motherboard
*AMD Ryzen 5 3600 CPU
*EVGA Geforce GTX 1660TI
*Corsair CX750M PSU (Used; Under a decade old)
 
Oct 18, 2020
9
0
10
0
You will need to boot with a graphics card since the Ryzen 3600 has no built-in graphics.
Have you tried clearing the CMOS?
Have you tried booting with just 1 stick of RAM in DIMM slot A2?
Have you tried booting with no drives connected to see if you can get into the BIOS?
I have not tried clearing the CMOS, nor have I tried the DIMM A2 or the no drives option.
I will try the ram option first, then to the no drives option. I don't know much about the risks of clearing CMOS, so I want to save that for last.
 
Oct 18, 2020
9
0
10
0
I have not tried clearing the CMOS, nor have I tried the DIMM A2 or the no drives option.
I will try the ram option first, then to the no drives option. I don't know much about the risks of clearing CMOS, so I want to save that for last.
I will attempt these tomorrow, since it getting pretty close to night for me (Hawaiian time).
I will inform you of the results tomorrow.
 
Oct 18, 2020
9
0
10
0
I will attempt these tomorrow, since it getting pretty close to night for me (Hawaiian time).
I will inform you of the results tomorrow.
I have tried seeing the PC would output onto the monitor with the HDD disconnected and only one DRAM stick in slot a2. The monitor still shows no changes whatsoever (No signal, remains a black screen no matter if the PC is on or not).
I would be willing to attempt a CMOS clear, but I have warranties on all my machines (I had to use the Newegg warranty on the motherboard, since the first one had damage on all but the b1 DIMM), so I don't know if there is a risk of damage or if the warranties would be voided by clearing the CMOS.
 
Oct 18, 2020
9
0
10
0
I have tried seeing the PC would output onto the monitor with the HDD disconnected and only one DRAM stick in slot a2. The monitor still shows no changes whatsoever (No signal, remains a black screen no matter if the PC is on or not).
I would be willing to attempt a CMOS clear, but I have warranties on all my machines (I had to use the Newegg warranty on the motherboard, since the first one had damage on all but the b1 DIMM), so I don't know if there is a risk of damage or if the warranties would be voided by clearing the CMOS.
NOTE: I have observed the PC's internals whenever I power it on (Glass window frame). The PSC lights on the Motherboard will light up for the BOOT and VGA LEDs for five to ten seconds, then they go off and don't come back on. During the period when the PSC lights are on, I observe the GPUs fans spin up but then spin down when the lights turn off.
 
Oct 18, 2020
9
0
10
0
WE GOT BIOS!
I'll keep y'all up to date on further issues, since I am running without full RAM or HDD.
Device is able to enter BIOS with RAM in secondary DIMM slots and HDD connected.
Thanks for the help and suggestions, it is a huge relief to finally be able to use my machine!
 

ASK THE COMMUNITY