Question New PC build - constant BSOD errors, unable to install any drivers

Page 2 - Seeking answers? Join the Tom's Hardware community: where nearly two million members share solutions and discuss the latest tech.
Mar 2, 2021
14
1
15
0
It varies, recently it crashes almost instantly, sometimes before boot, sometimes maybe a few minutes after boot. Other times it survives a bit longer. Currently it looks like safe mode isn't instant crashing, have left it on for about ~10 minutes, will update you otherwise.

Yeah I wanted to wait to try ubuntu just in case you wanted more error files from windows.
 

gardenman

Admirable
Moderator
I ran the dump files through the debugger and got the following information: https://jsfiddle.net/h2k91xqu/show This link is for anyone wanting to help. You do not have to view it. It is safe to "run the fiddle" as the page asks.
File information:030621-7156-01.dmp (Mar 6 2021 - 03:51:51)
Bugcheck:CRITICAL_PROCESS_DIED (EF)
Probably caused by:ntkrnlmp.exe (Process: svchost.exe)
Uptime:0 Day(s), 0 Hour(s), 01 Min(s), and 10 Sec(s)

File information:030621-6187-01.dmp (Mar 6 2021 - 04:36:04)
Bugcheck:DPC_WATCHDOG_VIOLATION (133)
Probably caused by:ntkrnlmp.exe (Process: Spotify.exe)
Uptime:0 Day(s), 0 Hour(s), 04 Min(s), and 09 Sec(s)

File information:030521-7359-01.dmp (Mar 6 2021 - 02:33:48)
Bugcheck:IRQL_NOT_LESS_OR_EQUAL (A)
Probably caused by:memory_corruption (Process: steam.exe)
Uptime:0 Day(s), 0 Hour(s), 01 Min(s), and 08 Sec(s)

File information:030521-6609-01.dmp (Mar 6 2021 - 02:32:15)
Bugcheck:DPC_WATCHDOG_VIOLATION (133)
Probably caused by:ntkrnlmp.exe (Process: steamservice.e)
Uptime:0 Day(s), 0 Hour(s), 05 Min(s), and 27 Sec(s)

File information:030521-5843-01.dmp (Mar 6 2021 - 02:26:24)
Bugcheck:DPC_WATCHDOG_VIOLATION (133)
Probably caused by:ntkrnlmp.exe (Process: System)
Uptime:0 Day(s), 2 Hour(s), 34 Min(s), and 18 Sec(s)
This information can be used by others to help you. Someone else will post with more information. Please wait for additional answers. Good luck.
 
Mar 2, 2021
14
1
15
0
Hello, I have been playing around with Ubuntu for a bit (first time using it..) and no errors / crashes so far? not even sure what it'd look like but its actually nice to use lol. The install did fail once at the start but they asked me to restart and after that it seemed to work fine. So does that mean all my hardware is likely to be working as intended? and its something about my build and windows that dont like one another?
 

Colif

Win 10 Master
Moderator
Linux isn't as stressing or demanding on PC as windows can be so try running tests on your hardware in it and confirm its okay.
Linux will run on almost anything, so it being fine doesn't necessarily mean its a windows problem

  • AMD Ryzen 5 5600x
  • EVGA Nvidia 3070
  • MSI MPG B550 Gaming edge
  • Gskills 16 (2x8) DDR4 3600 CLL16
  • Cosair 650w 80+ GOLD
  • Noctua NH-U12S Cpu cooler
you can't go backwards very far, your PC is pretty close to new, so if anything you probably need newer drivers. or BIOS. Its the entire platform that is shaky, you can't isntall any drivers or when you do it crashes.

there is a new BIOS, its a beta and was released on the 5th. It might help, I don't normally suggest beta but your CPU/MB is so new its possible it could be a compatibility issue - https://www.msi.com/Motherboard/support/MPG-B550-GAMING-EDGE-WIFI
 
Mar 2, 2021
14
1
15
0
Linux isn't as stressing or demanding on PC as windows can be so try running tests on your hardware in it and confirm its okay.
Linux will run on almost anything, so it being fine doesn't necessarily mean its a windows problem


you can't go backwards very far, your PC is pretty close to new, so if anything you probably need newer drivers. or BIOS. Its the entire platform that is shaky, you can't isntall any drivers or when you do it crashes.

there is a new BIOS, its a beta and was released on the 5th. It might help, I don't normally suggest beta but your CPU/MB is so new its possible it could be a compatibility issue - https://www.msi.com/Motherboard/support/MPG-B550-GAMING-EDGE-WIFI
What other test could I run ? I've ran CPU stress test with no issues, memtest with no errors...
 

ASK THE COMMUNITY