[SOLVED] New PC Build, everything starts up, one short beep from motherboard speaker but nothing on display...HELP!!!

Jan 30, 2020
1
0
10
0
I bought all components to build my new PC and aftet putting everything together, when i starting up, everything is powering, fans, lights on motherboard, light on case, also one shrot beep from speaker on MB, etc... But nothing on display. I tried different VGA cable, SATA cable and nothing works. I don't have a graphic card yet so i am using mu CPUs integrated graphics. Is this maybe my problem? I really need some help, can anyone help me??
MB: ASUS PRIME A320M-K
CPU: RYZEN 5 2600X
No GPU, using CPUs integrated GPU
 

oldcracc

Great
Apr 10, 2019
134
17
95
3
As stated above, your CPU doesn't have an integrated GPU; if your not planning on playing games, and you don't need a powerful GPU, you can pickup a cheap card to use as a display like a GT 710, but don't expect to be running too many games with it.

You could also return your CPU and pickup one with an APU such as the Ryzen 5 2200g/2400g, has integrated vega graphics, which aren't too bad, and should work with your current motherboard.
 

oldcracc

Great
Apr 10, 2019
134
17
95
3
As stated above, your CPU doesn't have an integrated GPU; if your not planning on playing games, and you don't need a powerful GPU, you can pickup a cheap card to use as a display like a GT 710, but don't expect to be running too many games with it.

You could also return your CPU and pickup one with an APU such as the Ryzen 5 2200g/2400g, has integrated vega graphics, which aren't too bad, and should work with your current motherboard.
 

ASK THE COMMUNITY

TRENDING THREADS