Question New pc build issue - continuous long beeps.

Oct 17, 2021
17
0
10
0
Hi all,

new here but looking for some help. I am bit of a newbie to building pcs and I think I done a stupid thing.
I bought all the components for a starter gaming pc and am having issues.

the pc starts fine but after about 30 seconds it starts to beep. Long beeps and continuous. So..

beeeeeppppppp, beeeeeeeeppppppp, beeeeeepppppp. If you get what I mean. It’s a standard long beep but multiple of them.

everything is brand new, and installed right and checked for compatibility but still this happens. I bought a CPU without a GPU installled and got a GPU for it, but it just doesn’t do anything but the above.


any support would go a long way.

thanks Byron
 
Oct 17, 2021
17
0
10
0
Ok so do you have beeping while windows is showing in dispaly? Or is it when you turn on the pc things come alive, fans spin, but no display is seen and the long beeps start?
hi,

the windows hasn’t been installed yet, so it happens slightly after start up. So I power it on and about 30s later it starts.


the build is all new

gigabyte motherboard
I5 10600k (no GPU)
2x16Gb 3200 RAM (checked compatibility with MB)
126GB ssd - for ops
500 GB M2 SSD
and
AMD 6700 xt GPU

i kind of thought my skills were better than they are, so this happen.
 
Oct 17, 2021
17
0
10
0
Just asking, when installing the motherboard you did install the offsets? There is a cooling fan installed on the cpu? Did you try using the motherboard display port to hook monitor up to?

Hi,

Cant et a different RAM, but tried a single one and the issue is still there.

as for offsets, yes, they were already there, except there is 'one' screw/offset that isn't used. basically the motherboard is not attached in one corner as there wasn't an offset hole
there for me to attach too. Can that course an issue? all other holes are screwed in to a offset.

Thanks
 

ASK THE COMMUNITY