Question New PC Build - No Post (Asus motherboard with Yellow Green QLED)

Dec 13, 2020
4
0
10
0
My New PC Build is stuck with No Post and a yellow Green QLED.
The components in my build are
a) Case: Fractal Design Meshify 2 XL
b) CPU: Ryzen 9 3900XT
c) Graphics Card: RTX 3070 Aorus Master
d) Motherboard: Tuf Gaming X570 Pro Wi-Fi
e) Cooler: Celsius S36 + 5 Prisma fans
f) SSD: Samsung 970 EVO PLUS 500GB M.2 NVMe
g) RAM: Corsair Vengeance RGB PRO Black 16GB * 2 - 3200 MHz DDR4 Dual Channel

https://uk.pcpartpicker.com/list/mcKyt8

I have checked the following
  1. Removed the SATA Hard Disk and left only one m.2 SSD
  2. Currently only keyboard and mouse are connected in the back panel along with HDMI to the Graphics card
  3. Checked and confirmed power cables to CPU, motherboard and graphics card are mounted correctly (I have two 8 pin connectors to the RTX 3070)
  4. Checked and confirmed front panel elements (LED, Audio, USB 3.2 and USB 3, Power and Reset) are mounted correctly (as far as I can tell)
  5. Reconnected RAM modules and confirmed that they are in the right A2 and B2 slots (2nd and fourth). I also tried leaving only one of the RAM modules in the recommended A2 slot)
I am a little reluctant to disconnect everything and trying assembly outside the case. (realizing I probably should have done that in the first place). Most step by step PC assembly instructional videos (including the top rated YouTube posters) don't make this suggestion - though almost all the troubleshooting instructional videos suggest this is the obvious best practice :-(

I am currently awaiting delivery of a motherboard speaker and would greatly appreciate any suggestions / pointers that I can try without a motherboard speaker,
This is my first build and am wary of using a screwdriver to short the power pins and suggestions along these lines - would ideally like to avoid drastic sounding steps.

Has anybody managed to complete a build along the above lines on the Tuf Gaming Pro WiFi motherboard ? (am not finding too much content specific to this motherboard - I know it is fairly new).

Regards
Sriram

P.S: the steps followed for the build are listed below

Stage 1Order components and create windows installation media
Stage 2Prepare Case
2.1​
Remove Side and Top Panels
2.2​
Install Power Supply
Stage 3Setup Fans
3.1​
Mount 2 of the Prisma RGB fans at the front (top 2) + 1 non RGB fan in front panel
3.2​
Mount a Prisma RGB fan as back exhaust
3.3​
Remove 1 hard disk cage to accommodate fan at bottom of case
3.4​
Mount 1 Non RGB fan at the base of case
Stage 4Setup Motherboard
4.1​
Install CPU
4.2​
Install RAM modules - A2 & B2 slots (2 and 4)
4.3​
Install m.2 SATA
Stage 5Mount Motherboard
5.1​
Install I/O Panel on side of case
5.2​
Mount the motherboard to the case
5.3​
Connect Case Front I/O cables to the motherboard
Audio cable at bottom left of MB (position 15)
Front Panel cables at position 17
USB 3.2 Gen 2 - position 8
USB 3.0 - position 9 (USB 3.2 Gen 1 header)
Stage 6Connect Fans
6.1​
Connect Prisma RGB fans to the 3-pin hubs for non-PWM control on the case
6.2​
Connect 2 non RGBk fans to the 3 pin fan hubs on the case (not PWM)
6.3​
Connect case fan hub to motherboard position 4 and connect power supply to fan hub
6.4​
connect daisy chained RGB fan cables to position 11 on motherboard
Stage 7SATA Hard Disk
7.1​
Install 4 TB Hard Disk in bottom chassis (required removing one intake fan)
7.2​
Connect power cable from PSU and SATA cable to Motherboard
Stage 8Connect Power Cables
8.1​
Connect 24 pin power cable to Motherboard
8.2​
Connect 8 pin power cable to CPU
8.3​
Connect power cables for Fans (SATA connector)
Stage 9Install AIO cooler
9.1​
Assemble Fans at bottom of radiator in pull / exhasust mode (fan facing down)
9.2​
Connect Radiator to top panel - towards front of case panel
9.3​
Install Top Panel (push out fan and RGB cables, Connect fans to 3 pin hubs on case (potentially replace with Fractal Adjust R1 hub later)
9.4​
Screw on pump unit on top of CPU mounting pins (remobe Intel adaptor and screw on AMD adaptor)
9.5​
Connect power cables for AIO, connect fan and RGB cables to daisy chained RGB cables from the front Prisma fans - which are connected to the ARGB header
Stage 10Install Graphics Card
10.1​
Remove extension slots 2 and 3 from back of case
10.2​
Install Graphics Card
10.3​
Connect 2 8 pin Power Cables
Stage 11Cable Management
11.1​
Complete positioning combs on braided cables connecting to MB/CPU/GC
11.2​
Velcro / Zip tie cables in the back panel
Stage 12Start PC
12.1​
Insert Windows installer USB
12.2​
Connect Monitor, Keyboard and mouse
12.3​
Powerup PC
NO POST
 
Last edited:
Dec 24, 2020
1
0
10
0
I just finished my PC build with similar specs to yours and I’m having the same issue. Have you figured out the problem?
 
Dec 13, 2020
4
0
10
0
I just finished my PC build with similar specs to yours and I’m having the same issue. Have you figured out the problem?
I have just made some progress. I ordered a new PSU based on a suggestion on another forum - and have had a sort-of-successful bench test after reconnecting the components with the new PSU and cables. At this point, I have the "CPU Fan Error! - Press F1 to run setup" displayed, but suspect this is because the AIO cooler needs to be setup from within the case.
 

ASK THE COMMUNITY

TRENDING THREADS