• Now's your chance win big! Join our community and get entered to win a RTX 2060 GPU, plus more! Join here.

    Meet Stan Dmitriev of SurrogateTV on the Pi Cast TODAY! The show is live August 11th at 2:30 pm ET (7:30 PM BST). Watch live right here!

    Professional PC modder Mike Petereyns joins Scharon on the Tom's Hardware Show live on Thursday, August 13th at 3:00 pm ET (8:00 PM BST). Click here!

Question New PC build not posting or beeping

May 15, 2020
2
0
10
0
I'm working on my first build, and it is not posting or beeping. I've been searching different forums for what seems to be the issue, and so far nothing has worked. I've reseated both RAM cards, tried to boot it with only one or the other plugged in, taken out the GPU, reinstalled the CPU (thermal paste and all), and checked all of the cable connections. I'd really appreciate any suggestions!! From what I've read, no beeps tend to mean issues with the motherboard, power supply, or CPU. I don't believe it's with either of the first two, cause all of the fans (CPU heat sink, power supply, and GPU fans) are spinning consistently during power up. Before I bring the CPU back to the store to ask for help, I just want to know if there's anything else I've possibly missed!

Here is the list of build materials:

AMD Ryzen 7 3700x
TUF B450M-PLUS
Gigabyte GEFORCE GTX 1660
Powerspec 650W
Inland premium 256G SSD
G.Skill Ripjaws V 16GB (2 x 8GB) DDR4-3200 PC4-25600

Any ideas would be much appreciated! Thank you!!
 

EndEffeKt_24

Notable
Mar 27, 2019
659
157
1,140
30
Any debug LED on that board that might help us?
Anyhow I would try to assemble the build outside the case with one ram stick and only the boot drive. Do you know someone who can borow you another ryzen cpu to test?
 

ASK THE COMMUNITY

TRENDING THREADS