Question New PC Build: PCI-to-PCI Bridge error with SoundBlaster AE-7

Jan 19, 2021
1
0
10
0
Help! I'm trying to setup my new PC build, and I'm running into an issue I can't seem to work through. This build is using an ASUS ROG STRIX B550-F board with a Ryzen 7 3800 XT processor and an EVGA NVIDIA 1650 GTX graphics card. The power supply is a Corsair RM850x.

The system is running fine, but when I install my SoundBlaster AE-7 card in one of the PCIe x1 slots (this card has worked fine in my previous system), it will randomly disappear from the system on each restart - sometimes it will be available, sometimes not. When it is not available, I will get an error in Device Manager regarding one of the PCI-to-PCI Bridge entries has a Code 31 error: This device is not working properly because Windows cannot load the drivers required for this device - The specified request is not a valid operation for the target device.

I have installed the latest chipset drivers for this motherboard and the latest BIOS. I've tried removing the PCI-to-PCI bridge from Device Manager and letting Windows reinstall it, but I get the same error. I have tried reinstalling Windows 10 several times (tried different feature releases) and have gotten the same issue. This has happened prior to and after installing the latest updates. Occasionally, after a restart the card will show up and work just fine, but on the next restart it will disappear again. I've even tried installing Linux with the 5.10 kernel that supports this card, and it worked fine until I restarted the system again. Could this be a setting in the BIOS I'm missing? The onboard sound device is disabled in BIOS when I've installed the SoundBlaster, but maybe there's a PCIe setting I've overlooked.

My understanding is that The M.2 and PCIe x16 slots closest to the CPU will be the ones that are fed directly by the CPU, which is where I have my GPU and my M.2 drive. There are no other cards installed, and I've tried using each of the remaining PCIe slots with the same results. I'm currently working with ASUS and Creative support, but so far, they're only concerned if I've restarted the system (yes, I have...several times, with different results, as detailed above).

Thanks in advance!
 
Last edited by a moderator:

ASK THE COMMUNITY

TRENDING THREADS