New PC Build. Poor performance. Windows has detected perfromance is slow.

Nickel5

Honorable
Dec 20, 2013
4
0
10,510
0
Hello

I just built my first pc and have had several performance related difficulties thus far.

When performing simple non-stressful activies, such as browsing the internet or even just navigating the desktop my mouse icon will freeze and jump around. Programs take much longer to install/open/close than they should.

I've also noticed intermittent choppy gameplay on Assassins Creed Black Flag.

Most recently the windows dialog box appeared saying my computers performance is slow and wants to change some video settings.

As i said this is my first build so my experience is nil.

My Specs are thus:

Intel 4670k (non overclocked) - stock cooling.
1x8 GB DDR3 Ballistix
Asus z87-a mobo
EVGA GTX 780 SC w/ACX cooling
XFX Pro850 Black Edition Full Modular PSU

Thanks for any help in advance

 

maninpain1980

Honorable
Dec 20, 2013
7
0
10,510
0
First thing I see wrong is stock cooling for your cpu. Get anything other than what comes with it.
didn't tell us what you have totally so I'm gonna guess.

for performance boost get you a 128 gb SSD and only put windows and 1 or 2 games you play at that time on it then copy and paste it to your HDD.

for fans I have 4 fans in my coolermaster mid tower all are 120 mm

can check your temps by downloading CPU-Z but im guessin it's a heat issue

for example I only have a 560ti oc 28 -37 have been my max temp on my card and my cpu is 34 all temps are @ C and all I have atm cooling my cpu atm is a H-50 radiator by corsair but it does its job.

get something like this
Corsair Hydro H100 CPU Liquid Cooler - 120mm Fan, LGA775, LGA1155, LGA1156, LGA1366, LGA 2011, AM2, AM3 - CWCH100/RF(Refurbished)


Corsair Hydro H100 CPU Liquid Cooler 69.00

http://www.tigerdirect.com/applications/SearchTools/item-details.asp?EdpNo=8245954&Sku=C13-2100 RB
 

Nickel5

Honorable
Dec 20, 2013
4
0
10,510
0
maninpain1980, I plan to get a Noctua for cooling in a few days. I guess an SSD is a possibility but I'm moving across the country in a few weeks so budget is limited.

I've got a Corsair 540 w/3 big fans so I don't think temps should be too bad, but like I said I'm looking into a CPU cooler at the moment.

I'm a little worried that there might have been some static discharge on the 780 when I first got it. Like I said this is my first full build by myself and when it first arrived I had to open it up right away in anticipation and like a dumb*** I didn't ground myself first.

(Is that a possibility for what I've been experiencing or would I have noticed more dramatic problems if that was the case?)
 

Similar threads


ASK THE COMMUNITY

TRENDING THREADS