[SOLVED] New pc build, usb ports not working

Aug 30, 2019
7
0
10
0
Hello,
I just build my first pc but sadly it doesnt work as it should. When i turn it on all the fans work(case fans, cpu fan, gpu fans) Also the rgb on case lights up but none of my usb ports work. When I turn on the monitor it shows the NOC logo but then it says no signal. I read that i should use usb 2.0 because 3.0 apparently needs a software to work but I can't find any usb 2.0 on the case or mobo. Pc parts list: Ryzen 5 3600 Rx 580 red devil Aorus b450 pro Ripjaws 5 2x8 3200MHz Bequiet 600w b9 PSU 2x be quiet 120mm fans Case: Antec dp 501
Looking forward to any replies !
 
Aug 30, 2019
34
1
45
1
Can you access the BIOS?

if not i had a similar problem, where my CPU (same as yours) was not compatiable with my motherboard. The fix was i had to change the CPU to a different model and update the BIOS making it compatible with my CPU, then all ports worked and i could access the BIOS and use the computer.

As not everyone has spare CPU's just lying around you might have to go to some sort of tech shop in order to fix it

This might not be the solution, but it worked for me
 
Aug 30, 2019
34
1
45
1
Can you access the BIOS?

if not i had a similar problem, where my CPU (same as yours) was not compatiable with my motherboard. The fix was i had to change the CPU to a different model and update the BIOS making it compatible with my CPU, then all ports worked and i could access the BIOS and use the computer.

As not everyone has spare CPU's just lying around you might have to go to some sort of tech shop in order to fix it

This might not be the solution, but it worked for me
 
Aug 30, 2019
7
0
10
0
Can you access the BIOS?

if not i had a similar problem, where my CPU (same as yours) was not compatiable with my motherboard. The fix was i had to change the CPU to a different model and update the BIOS making it compatible with my CPU, then all ports worked and i could access the BIOS and use the computer.

As not everyone has spare CPU's just lying around you might have to go to some sort of tech shop in order to fix it

This might not be the solution, but it worked for me
No, you are right i cant access the BIOS.
Also when i turn on the PSU there is a short flash around the motherboard maybe its connected to the case?
 

ASK THE COMMUNITY

TRENDING THREADS