Question NEW PC BUILD WINDOWS CAN'T FIND DRIVE

Commonsense101

Reputable
Dec 23, 2015
22
0
4,510
0
Hello everyone,
I built a new pc with a ROG Strix B450-f Motherboard. I bought a new WD Blue 1TB to install Windows 10 on, which I bought USB. It shows the disc in the BIOS but when I get to the install part it doesn't find any drives to install it on???
I hooked up the drive to my other pc, formated and partitioned. Drive works fine. Plugged it back into the new pc, still shows but still not showing during windows installation. I'm stumped.
Appreciate any help you can give.
Thank you,
 
May 11, 2019
3
0
10
0
This literally just happened to me a few minutes ago. Check your Device Manager and see if it's there. Mine was, and Bios, but Win10 File Explorer wasn't seeing it. It wasn't in Disk manager either. So I looked in Device Manager and viola... it was "Disabled". I don't know why, as all i did was change out my PSU but hey, maybe it's that simple for you.
 

onespeedbiker

Prominent
Apr 13, 2019
598
30
490
11
I have read similar problems resulting from the USB being #1 in the boot disk order, confusing windows 10 in some instances. Go back to the bios and place the new HDD in the #1 position, then when you reboot, bring up the boot manager and chose the USB and continue as usual.
 

Commonsense101

Reputable
Dec 23, 2015
22
0
4,510
0
This literally just happened to me a few minutes ago. Check your Device Manager and see if it's there. Mine was, and Bios, but Win10 File Explorer wasn't seeing it. It wasn't in Disk manager either. So I looked in Device Manager and viola... it was "Disabled". I don't know why, as all i did was change out my PSU but hey, maybe it's that simple for you.
Can’t, new pc fresh install. Trying to get it installed yet
 

Commonsense101

Reputable
Dec 23, 2015
22
0
4,510
0
I have read similar problems resulting from the USB being #1 in the boot disk order, confusing windows 10 in some instances. Go back to the bios and place the new HDD in the #1 position, then when you reboot, bring up the boot manager and chose the USB and continue as usual.
I’ll give it a try.ty
 

onespeedbiker

Prominent
Apr 13, 2019
598
30
490
11
Another thing to try is to make sure the bios is set to CSM mode. Your motherboard was designed to use a M.2 NVMe SSD (two actually), so it may take a little more tweaking than usual to use an old style Sata HDD. You may want to also disable disable ami native NVMe support when you are using a SATA HDD.
 
Last edited:

Commonsense101

Reputable
Dec 23, 2015
22
0
4,510
0
Another thing to try is to make sure the bios is set to CSM mode. Your motherboard was designed to use a M.2 NVMe SSD (two actually), so it may take a little more tweaking than usual to use an old style Sata HDD. You may want to also disable disable ami native NVMe support when you are using a SATA HDD.
I'll give it a try. Thank you!
 

ASK THE COMMUNITY

TRENDING THREADS