[SOLVED] New pc build won't boot but fans turn on and off in a loop?

Apr 21, 2022
22
0
20
0
I recently built my first ever pc , when I went to turn it on , I flipped the PSU switch and all the fans turned on (case fans,PSU fan,GPU fan,CPU cooler) for a few seconds then turned off and kept doing this in a loop . The PSU also makes a clicking sound whenever the fans turn on again . I suspect it's a ram problem because if I take out both ram sticks the fans stay on instead of looping but the pc still doesn't boot (because there is no ram) . I have 2 ram slots and tested each one with each ram stick , still the same issue . Does anybody have any insight into this issue . Thanks in advance.
 
Last edited:
Apr 21, 2022
22
0
20
0
full system spec? include brand and model of the psu
PSU : Corsair cx550 modular 550w
CPU: Intel i5 3570
GPU : gtx 960
Motherboard : I'm not sure exactly what it is but it's a Dell optiplex 390s motherboard with LGA 1155 socket and ddr3 ram slots
Ram: gigastone 2x8gb ddr3
SSD : Integral v series 120gb SSD
 

logainofhades

Titan
Moderator
You managed to put a Dell motherboard into a standard ATX case? Usually that is not possible, as Dell makes everything proprietary. A second gen chip would be less hassle regardless. No need to reinstall windows. 3rd gen really isn't much different, vs 2nd gen, performance wise.
 
Apr 21, 2022
22
0
20
0
You managed to put a Dell motherboard into a standard ATX case? Usually that is not possible, as Dell makes everything proprietary. A second gen chip would be less hassle regardless. No need to reinstall windows. 3rd gen really isn't much different, vs 2nd gen, performance wise.
I didn't have any problems putting in the motherboard , although I had trouble with the pwrsw slot which was 5 pin but I got it working . Anyways thanks for the heads up .
 
Apr 21, 2022
22
0
20
0

ASK THE COMMUNITY